Kling-Net dropouts after opening TD

Hey everyone,

This is kind of a follow-up to my previous post. For context, I am a DJ and have been running a TD file to control my lights & visuals at shows for the past few years. This has led to me doing installs at some of the venues where I perform as well. I am currently trying to implement ADJ Pixie Strips into our stage setup. These lights work most efficiently using the Kling-Net protocol, so I recently purchased ArKaos MediaMaster to drive the strips while pumping content from TD into MM via NDI. I am then controlling values in TD via OSC/PILOT live on stage.

I mapped the strips inside of the MM Kling-Net mapper and everything was working fine. I made a handful of patterns in TD using Ramp TOPs last week, hit the road for some gigs over the weekend, came back to the studio to continue working on the lights and now I’m getting some pretty frequent network dropouts from MM. I did some research and apparently Kling-Net likes the 2 dot and 10 dot IP range best, so I made sure my network was set to the 10 dot range to be safe.

What’s weird is that when I have MM open by itself, the connection is stable, but as soon as I open TD the dropouts begin. I initially thought that it may be due to my computer being under load, with TD sending out DMX, OSC, NDI, and also rendering my visuals, so I opened a blank TD project as a test and had the same issue. My usual TD network is pretty well-optimized for how large it is anyway, but I’m kind of out of ideas now. Trying to get this resolved as quickly as possible so I can use these lights on stage, but I also have some clients interested in adding the same lights to their venues, so I need the connection to be reliable. The only thing I can think of is to have a separate machine to run MM instead of sending everything over my local network on one machine, but that would honestly be a pain and I would love to run everything off of my current rig if possible. I’ll list my specs down below as well:

Lenovo Legion 7 Pro
Processor - 13th Generation Intel Core i9-13900HX
Graphics Card - NVIDIA GeForce RTX 4080 12GB GDDR6
Memory - 32 GB DDR5-5600MHz

Any help would be greatly appreciated, thanks as always!

You should definitely be able to run both programs at the same time, especially with that hardware, and it sounds like you WERE doing so with no issue before something changed, so concentrate on trying to remember all the little things that may have changed in the interim… Did you update TouchDesigner or MediaMaster? Run Windows Update or plug in any new hardware? New router? New network switch? Different lights? More lights? Other different hardware involved on the DMX / KlingNet side?

The problem may be triggered when you open TD, but if you didn’t update or change anything specifically with or in MediaMaster or TouchDesigner, the actual issue is probably not with either piece of software. It’s not like TD has a secret “Start Arbitrarily Messing With Network Signals If Current Date Is After Late August Of 2023” feature or anything…

That’s what I was thinking too, it was really weird that it stopped working all of a sudden. Time to check if my system auto-updated somewhere lol

@Peeet Another update on this situation. Changed my network IP, opened everything up & all was working properly again. Worked on designs for a couple of hours, shut down the pixie strip driver box, turned it back on & now the lights aren’t connecting again. I guess it wasn’t an update issue after all, but something network related. Maybe TD & MM are conflicting over network protocol control ownership?

Yeah could be issues with the ports being opened IE if you are not opening the programs in the same order every time, one of them could be holding the ports hostage that the other needs. But what seems weird to me is that just opening up an empty TD file still causes issue. TD shouldn’t be opening ports until you actually put down a DMX Out CHOP or something.

The only other thing I can think of is that Windows will give different programs priority over your GPU based on what program has “focus” in Windows. Does it happen when one program is in focus vs the other? Does it depend on what order you open up the programs in?

Usually, problems like this are very often network related. I always try to make my networking as simple and sparse as possible (aka static IP addresses and Unicast everywhere) so if you are unsure about your network setup - especially if you don’t firmly understand static IP addressing and unicast vs broadcast vs multicast, then you could be inadvertently using settings that aren’t quite matching up with eachother or creating conflicts.

What exactly do you mean by “changed your network IP”? and also how is the Pixie strip driver box set up… DHCP? static IP address?

I have my IP in my settings set to manual with the address being & a subnet. I changed the address to & it worked for a while until I switched the driver box off & on again. The driver box automatically assigns an IP address to the fixtures based on the address of my PC, so I have it set to static. No issue running automatic; but switched to static as I hear the 10 & 2 dot ranges are preferred for kling-net. Perhaps it has to do with the order the apps are opened, but I tried repeating the same steps as when it was working & no luck.

Are you saying you set your computer to those IP addresses? Or the driver box?

I don’t think that’s how it works - the pixie driver box couldn’t know explicitly what IP address your computer is… If you are going through some network device that has a DHCP server running, then that could be giving an IP address to the pixie driver box and causing it to change each time it starts up, but otherwise client devices like that either get a static IP that you explicitly tell them in their menu or physical control panel on the front of it, or if they are expecting DHCP and can’t find one, it will pick a random IP address in the 169.254.*.* range, which also could be different each time it starts up.

When it does that, MultiCast sACN and maybe parts of KlingNet will still work (if it truly is MultiCast) but only if you have an IGMP-snooping capable network switch in-between them (IE not directly linked with a single ethernet cable) and the MultiCast is reaching across subnets.

Again do you mean the PC is set to automatic or the pixie driver? or both? and if both, do you have a DHCP server? The 10.*.*.* and 2.*.*.* ranges are common for ArtNet - and 10.*.*.* range is generally more “correct” and compliant to TCP/IP spec - but also usually you are supposed to use a subnet mask instead of and depending on if you are using sACN, ArtNet, or KlingNet, parts of each protocol may or may not work in different IP / networking situations (especially if there is a subnet mismatch because of different subnet masks)

Unfortunately when it comes to networking and complex setups like this, the devil is in the details, and I can’t help but feel like you might be un-knowingly skipping over some minor step or element of your setup that may explain what’s going on. If you don’t have the time between gigs to settle down and methodically step through everything very “scientific method”-like (I know I often don’t have time for that kind of focus), then you may just have to try using only MediaMaster - or something other than TouchDesigner if that really does “solve” the instability.

Sorry I couldn’t be of more assistance, good luck!