Leap motion for m1 macs

Could we please have the Leap motion chop and top enabled for mac m1 chips!! I got the leap motion to work on my m1 mac though previously I thought it was outdated but it’s working on my m1 mac, would be nice to have touchdesigner working with it too!!

Hi,

Thanks for the information. I know Leap mentioned they were going to do an M1 version a few years ago, but my understanding was that they still hadn’t released anything new for Macs. When I did try it on an Intel Monterey system, it wouldn’t detect the device at all.

What Mac OS are you running and what version of the Leap drivers did you get working?

I saw this link ( Leap Motion Controller Python SDK on Apple M1 - brett warne ) where someone got the old python interface working using Rosetta - is this something like you’re doing?

I ran into the same issue with leap but I downloaded version 2.3.1. and though it says it is not compatible with macOS Monterey, I went ahead and installed it. I had to troubleshoot, recalibrate and restart my m1 mac but it worked! I am able to detect the leap motion now on my laptop but touch designer is not sensing it yet. I’m using an Apple m1 chip mac running on Big Sur version 11.4. Let me know if there are other ways to make the leap talk to touch designer!

Thanks for the details. I’m a little wary of enabling when it’s not going to work well for most m1 users (those on Monterey+), but I’ll talk to the team here and see what we can do.

Thank you so much! Appreciate it!

Have you tried it running our Intel Mac build on your m1? That version does have Leap enabled, so in theory it should work if you’ve got the driver running properly. Unfortunately we don’t have a Big Sur M1 system available to test it here.

I tried running it and I got this error, I installed the libLeap.dylib file in my local libraries folder but I’m getting this error still

When you say the local libraries folder, I assume you mean ‘usr/local/lib’? That should work, but you could try the frameswork folder inside the TouchDesigner package contents as well (I think you right-click on TouchDesigner.app and select open contents). The folder should be something like TouchDesigner.app/contents/frameworks.

We’ve only tried this on Intel Macs, so I don’t know if there’s anything else on the M1 that could be preventing the library from loading. Do you need to specify that a library should be run through the Rosetta translator?

That worked!! Thank you so much for the help :smiley:

1 Like

Hi,
I just want to say thank you so much and precise that I’m on a M1 Pro on Monterey 12.1 and all the trick works. The trick on restarting the mac after “recalibrating the device” (which do nothing lol) on the leap motion control panel and after putting the libLeap.dylib in the framework folder of Touchdesigner works. I have all my datas on the Leapmotion CHOP :smiley: !

This topic also helped me for the trick of the “restart”: https://forums.leapmotion.com/t/leap-motion-on-m1-mac-monterey/18535/3

PS: (I just bought my leap motion yesterday so your conversation is perfectly timed)

Have a nice day :sun_with_face:

2 Likes

Hi, I downloaded the latest version of TouchDesigner (2022.29850) and now I have this message : Error: This node is not supported by this operating system But I know that it was possible with an older version. So do you know how to pass this restriction when we are on Monterey 12.1 ? Thanks in advance !

The Leap Motion CHOP is not currently enabled on the arm64 version of 2022.29850 for MacOS, but it is available on the Intel build which can still be used on an M1 machine.

Which version did you have running before?