Leap Motion - Mac Inter / Mac OS Ventura - TD 2022.29850 - Not working


Mac OS Ventura 13.5.1 (22G90) (Intel MBP 2019) and TD version 2022.29850

I installed Leap motion driver. It is working fine with it’s own app, but not in TouchDesigner.
TD shows that “Leap Motion library and/or drivers could not be found”.

I tried everything I could find so far.
I put the file “libLeap.dylib” in “usr/local/lib” and “TouchDesigner.app/contents/frameworks” .
I tried to restart the computer.
Unfortunately, they still don’t work. :smiling_face_with_tear:

Unfortunately, I don’t think the existing Leap Motion operators work on Mac OS after version 11 (at least that is what Leap’s documentation said). You also need to make sure you’re using their old Mac drivers (2.3.1) that are now only available on their legacy page here: TRACKING SOFTWARE MAC 2.3.1 — Ultraleap for Developers

We are in the process of updating to the newly released Gemini drivers for OSX, but they are not quite ready yet. We hope to have those available in one of the upcoming 2023 experimental releases.

Wow, Thank you so much! I solved the problem!
I think it’s the driver version. I try to installed it , and it worked! :smiling_face_with_three_hearts:

Glad it worked and thanks for letting us know.