Lister - unable to use custom Col Parameters with Linked Table


Windows 10 Pro Build 2020.22080

I add a table to input parameter.

Input Table has Headers On
Auto Sync Input Table On

at this point turning off Auto Define Columns throws an error.

Do you have any ideas what may be causing this?

Turning off auto-define column assumes you have a properly set up colDefine DAT. Looks like you don’t. You might try Copy Auto Cols To Config, first. To edit your colDefine, click Edit Column Definitions. That particular error looks like you are missing a column label.

If none of this works or makes sense, attach your file here I’ll take a look


It appears to be related to using Arabic text within the input Table.

If i create a simple table with only english in I have no problems.

Ive actually found a better solution to what I was trying to achieve so there is pressing issue.

If you want a copy of project with Arabic to have a look at thats no problem

Sure I’d like to take a look when you have a chance

do you have an email i can send it to? The project is semi confidential… and VERY messy so rather keep it private…

Here is a small test project with CSV file I’m using.

I get the same error.

td (12.2 KB)

You just need a header in every column. Blanks cause problems


I though I had tried that… so I tried again.

Still getting same error. - results attched

I’m sure its user error but I cant see where I’m going wrong!

Thanks for your time.

td test (22.0 KB)

Ah, so there is another problem in your file. Not sure how it got there, but if you see it again definitely report again.

The problem is this: the ‘column’ cell (0,0) in your colDefine has a corrupted string in it. If you clear it out and then retype ‘column’ there, you should be okay. Lister also tried to be clever and replace the column row, which is why there’s a weird list of columns at the bottom. You can delete that entire row.

Let me know how this goes.


Thanks for the continuing help. As I have said this is not urgent but is an annoying issue for me as I work in the Arabic speaking world…

I think its an issue with Arabic…

I had a few minutes to spare so did some basic tests.

In order to get the Arabic spread sheet I am given to load correctly in Touch I export as a CSV file with UTF8 encoding from either Excel on my Mac or Open Office on my PC.

After this I have to open the file in Notepad on PC and then re-save with encoding set to UTF8 with BOM

If there is a better work flow I’d love to know!

In the test I have tables with file import from

1 - Arabic and no BOM
2 - Arabic with BOM
3 - same table with all Arabic deleted and some random english words no BOM
4 - same table with all Arabic deleted and some random english words with BOM

As you can see without BOM Arabic is garbage.

But lister doesn’t like it in either format!
Its works fine when there is no Arabic in table.


td test (29.1 KB)

Yes, using BOM marks is the current workflow you need to denote UTF8 encoded data. In the upcoming 2020.40000 series of builds (unreleased) we do have autodetection added though.

It turns out that this is a deeper bug. Will keep you up to date on what we come up with. Thanks for the nice test file!

Unfortunately this was too big of a bug to fix in the 20k branch, but it will work in the 40k experimental branch coming soon.

Thanks for your report.