live setup | separate monitors view


I’m struggling with my live setup. I can’t slip the view throw 2 monitors.I want to have my interface on the computer screen and to project my final video throw a projector.

I have both things (interface and final output) in separate containers that came together in another container which is the chosen one to show up in my perform window. So I have both side by side, but I can’t slip the two parts in different monitors.
When I chose to specify monitor it appears all the setup on monitor 0 or in monitor 1 depending on what I chose. When I select bounds of all monitors and select open size to fill (because my perform window width is twice the projector resolution width) shows up my interface and a piece of the final output in monitor 0 and nothing in monitor 1. I saw that exists a parameter called OpenGl Stereo but I don’t know if is related to this or how to use it.

I’m am quite lost and don’t even know if I’m doing right.
Anyone know any way to set up things to have interface in one monitor and final projection into another? :question:

Thank you!

here’s a video tutorial how to build exactly such a live performance interface. … hdesigner/

Basically if you have a monitor of 1920x1080 and a projector of 1920x1080, you’ll first need to set them up in your OS so the monitors and projector are aligned horizontally next to each other.
So if you move the mouse over the right edge of you monitor, it’ll show up on your projector.

Then in TD you create a single perform window which is 3840x1080, so it covers both monitor and projector. You can use Container COMPs to make sure your output is only in the right half and your interface is on the left half - see video above how to do that.

have fun!

PS no you don’t need opengl stereo (which is something completely different)

Thank you for your answer.

I already do saw this tutorial, in fact, I used the same measures and method that him. I also confirmed and my monitors are horizontal align and in correct order. I don’t know why doesn’t work.

Do have any idea of what can be causing this? Like some definition that I may be missing? Some parameters that a should turn off or on? I really don’t understand what’s going on! :neutral_face:

These settings should do it.
Also attached an example.
test_output.toe (3.45 KB)

The same problem persists! :frowning:

Doesn’t slip. In my monitor 0 appears half and a bit more that should appear on the monitor 1. Nothing at all happens to monitor 1. (check the image, it’s what appears in monitor 0 in perform mode)

Looks like my monitors don’t have the same aspect ratio resolution. My mac native resolution is 1280×800 (16:10) and my projector native resolution is 800×600 (4:3). Supposedly 800×600 is compatible resolution with mac but when I go to system preference, monitors and in resolution choose proportional it does not appear any option with 4:3 aspect ratio. Just appears the options 1280×800, 1152×720 and 1024×640, which are all 16:10.

Can this be the problem? Maybe they need to have the same aspect ratio? How can I make match the aspect ratio of one of monitor with the other?

Thanks for the help all this stuff is really new for me.
Captura de ecrã 2019-07-17, às 18.56.03.jpg

I tried something that maybe can work but I don’t know if it’s the most efficient way or if can kill my performance.

I made a container with the resolution of my screen where I have my interface which is the operator that I used for perform window. I set the parameter justify and offset to specify monitor to be 0 and set it to be my perform window.

I made another container with projector resolution where I have my final output. I made a second window and set the parameter justify and offset to specify monitor to be 1 and open it as a separated window. And now it shows up through the projector.

Then I click on perform mode and appears my interface in my screen. I test the interface (the effects sliders, movie bin, etc) and seems that everything is working properly. But I don’t if this is a good solution, mabye it reduces my cooking time?

Maybe totally unrelated but I found and saw with other people occasionally that performance window opens half way when opened with F1. Looks proper when opened with the open button. Will look into it and see if it is reproducable, but give it a try. Can’t hurt to try, maybe it solves you issue.

Hi stefan, thank u for the suggestion, but still not working! :frowning:

I must be missing something…

It does not matter if you monitor and projector are different resolution / aspect ratio.

The solution is still to make a single perform window which covers both (or is bigger).
So if your monitor is 1280x800 and your projector is 800x600, you make a container of 1280x800 for your GUI, and a container of 800x600 for your output. Combine there in a single Container COMP of 1280+800 (horz) x 800 (vert). Align the child containers vertically to the top.

You’ll also need to align your outputs in your OS so they also align vertically at the top.

If you align your perform window vertically also to the top & left of the left monitor, it should now cover both monitor and projector.
You would not need the fill option as the native resolution of the perform window, 2080x800,(taken from the final Container COMP) already covers both outputs.

PS and indeed the hack of using a second Window COMP for second output will seriously reduce your performance

I did it as you said and solve me half a problem. Now the left half, my interface, appears correctly in all my screen but nothing shows up in the projector.

Stranger is that I tried out with other monitor and happens the opposite. My right half, output, appears correctly in my second monitor but nothing shows up in my screen.

Do you mind check the project? Hopefully you can discover what’s going on! It’s making me crazy!
teste projector.6.toe (10.6 KB)

I found what is missing! I had the preference displays have separate spaces unable in System Preferences. Now that I disabled that preference it works properly. Nothing to do with TD preferences or setup.

Oh my god! I feel so stupid! But everything is solved at the end as it should.

Thank u a lot for your help and your time. :slight_smile:


Interesting. To be clear, you’re referring to macOS, correct?

Screen Shot 2019-07-21 at 12.08.21 AM.png