lock automated zoom in trail viewer

I am on an experiment to make a visualisation of a kind of Sinuswave. I have a lfoChop connected to the input of a trailChop. I can now see the trail of the lfo Chop as a wave. If I increase the the amplitude of the lfo the wave in the viewer ajusts according to the amplitude and zooms out after acouple of seconds, so that the wave then looks the same. But thats not what I want. I would like to lock the vertical zoom position, so that, depending on the amplitude of LFO the wave looks differnt. Is that possible somehow?

And by the way I woudl also like to hide of the vertical and horizotal lines in the viewer o the TrailChop, so that I only see the the wave. What about that?

Would be happy if someone could help me with that!

I also tried to do my own Sinus-Trail, with the help of feedbackTOP (see attachment) but I failed because of … I guess the samplerate? Also resampling didnt help. I only see the points instaed of a smooth trail.

Me too, I would like to have a way to set and lock the vertical and horizontal scales in a Trail node. Or is there another way to view a signal that offers such features ?

click the plus icon in the lower right of the Trail CHOP to activate its viewer pane.
Now right-click in the Trail node, you’ll see a popupmenu where you can disable autoscaling and set the hor/vert range you prefer, amongst many other display settings.
chop-range.gif
But for proper 3d visualization of a CHOP curve I recommend to check out the Chop To SOP and the Limit SOP.
See all the examples for both operators under Help->Operator Snippets->SOP->etc…

Ahh, lovely. Thanks so much.

When clicking “Home”, the vertical/horizontal adapt boxes are re-checked, even though if a custom vertical range is set, that is actually kept. That doesn’t seem logical - the horizontal/vertical adapt boxes should not be re-checked, unless home is meant to execute a full “reset” of all these settings. I am interpreting the Home function only as a way to re-position the graph to its default.

Also note that the time (horizontal) range is set as a parameter while the vertical range is set in view mode, where I was originally looking to set the horizontal range as well. Just a little confusing.

Another thing is that when setting the vertical range to “Other”, that other range has to be specified before “Other” is selected or it will not show in the graph and another range has to be selected first before again selecting “Other”.