Low FPS in default scene of TD.... Why?

HI ALL!!!
why the computer with 40 GB RAM and with the video card NVIDIA GTX 760 has low fps in TouchDesigner default scene? FPS runs between 45-55 fps
Im working in TD more then 3 years but did not have such bad resaults in fps speed.
I had different computers and laptops.
Maybe codec?
Or videocard not optimized to work with TouchDesigner?
I would be very grateful if you help me)

The first thing I’d check is that you are running the latest drivers from www.nvidia.com. Is this a laptop or a desktop? I’d also check the power saving options to make sure you arn’t running on a low-power setting

MY PC:

WIN 7 64 BIT i7 2.80GHz / 40 GB RAM /
NVIDIA GeForce GTX 760 DRIVER 382.53 (NEW) / DIRECTX RUNTIME FRESH
ON hdd C: more than 20Gb free space.

Power seems ok - top perfomance settings.

TOUCHDESIGNER 088 and TOUCHDESIGNER 099 the same problem.

The default scene FPS in 2 secounds changing in realtime from about 47 to 55(60) and back.
If I start default scene one more TD fps going more low about 35 to 50

youtu.be/6vfpTTipe3w

Thanks!

Hi gtouch33,
when I look at the nvidia drivers site, it see the current driver for win7 geforce GTX 760 is 384.76, instead of the 382.53 you are using.

Hmm… I will test this.
Thanks )) :wink:

Thanks a lot for your help.
I install new driver NVIDIA )
Start TD and see that FPS looks better but not ideal/ Now FPS 51 - 60 in 2 seconds changing.
sometimes going to 45 ( its not good. :slight_smile:

I will check other system parts. :exclamation:

The plan B is to make one more computer with RADEON videocard with 1GB video memory on Sabertooth x58 motherboard.

The following is only applicable if you are using a laptop:
-In TD, place a Monitor DAT and see in the column “description” what video card TouchDesigner is using. if you see something like “Intel HD…” it means it is running on the onboard (slow) Intel GPU instead of your Nvidia GTX 760. Then you can try to set in your BIOS or in your laptop settings to set your Nvidia card as the default card.

WHEN I set 60 to 30 fps in TD the interval between max and min FPS changed to 28 - 30 FPS.
I dont understand now why.

Thanks!
In TD Monitor DAT
I see only Nvidia GTX 760 for DISPLAY1 (I have 1 monitor)

I test in TD other FPS
and
10 FPS - is OK 10
55 FPS - is between 47 - 55
65 fps - 55 -61
100 fps and more - 51 - 61 fps MAX !
So I can use only <61 FPS

Be aware that the maximum fps you’ll get is linked to the maximum refresh rate of your monitor, which is probably 60hz. So you can’t use this as a benchmark. (You can disable vsync of your perform window to go beyond your monitor refresh rate, but you dont need that right now I guess).

My guess in finding speed is try to find if you have any other software/bloatware running (maybe in the background) which you can disable?

Hey guys. I’ve run into this exact problem on my MAINGEAR Element 3 (a Laptop)
Even in a blank default scene with no extra ops running, my FPS never breaks above 41FPS.

HARDWARE_1




TD_VERSION

I’ve also followed much of the advice on this thread (Including switching to the dedicated GPU in BIOS) to no avail.

Neither Driver Updates nor TD version updates seem to have an effect on the problem. I thought I’d revive the thread incase there are any new ideas .

I’ll also make sure to let you know if I fix it somehow

What does TouchDesigner’s Performance Monitor say when you click ‘analyze’.

What does the Windows Task Manager look like, are the CPU or GPU maxing out, or can you see other processes running at the same time?

An Update:

As it turns out, my problem was the NVIDIA Studio Driver.
It doesn’t play well with Touch for some reason.

I managed to fix my problem by switching to the latest Game Ready Driver.
All is well with my FPS now.

1 Like


Sorry Ben, I missed your reply at the time for some reason.
As it turns out, the problem is resurgent.
It seems sorted out for a few minutes after I update the Graphics Drivers. Everything gets back up to above 40FPS, but it all falls apart like clockwork the next time I open Touch. I’m not sure what to do.

To answer your question though.
Here’s a screengrab from an empty project

@scarletmotiff We discussed the issue here and have a few things to try.

  1. bloatware or 3rd party software that comes pre-installed on the laptop can cause major issues. We would recommend uninstalling anything from Windows you did not install yourself. If you search for “Bloatware” in this forum you will find many threads about the common ones people have found to cause problems. Generally with Windows laptops, it’s my habit to wipe them and reinstall a fresh Windows without preinstalled software as soon as I receive a new laptop.

  2. Power settings. Make sure the power settings of Windows is not limiting it, set it to High Performance. Also make sure your laptop is plugged in, most Windows laptops throttle down when just running on battery, you will get a fraction of the performance.

Let us know if either approach offers any results.

Ben, Thanks for the quick turnaround on this.
As it stands, short of a full reinstall of Windows and uninstalling Steam, I’ve done what you’ve suggested.
I even set it within windows so that Touchdesigner specifically opens with High Performance graphics settings.
That being said, I really don’t get why changing the graphics driver sorts out the problem only momentarily. It might be something to do with my specific system.

This wasn’t a problem until 3-4 months after I got the laptop. And it seemingly affects nothing else.
I’ll keep an eye on things on my end though.

One thing to check, are the temperatures in your laptop in check? You can monitor temperatures of CPU and GPU using HWMonitor application. Perhaps something is not being cooled correctly, fans not working, etc.