macOS Beta Known Issues

Please refer to this page for a list of known issues: macOS

is there a way to use codemeter dongles on osx?

Yep, the dongles are working on both. Contact support for help updating a dongle for 099.

I also notice that if you close a file with the red button/X in the upper left of window, there is no prompt to save your work. So you lost every change.

Thanks for the report about the prompt. We’ll look into it.

I can’t reproduce the issue with the prompt. If I open a TouchDesigner fresh, move a node and then click on the top left red X, I get asked if I want to save on exit. Let me know if you are doing something different. You should also check that Preferences->Prompt to Save on Exit is set (should be on by default).

Also, SSAO is not supported at all, correct?

Hi,

I’m having issues with camSchnappr. Mouse is only bing mapped to top left quadrant of camschnappr window and full crash when trying to turn wireframe off. not sure if this has been reported.

Cheers,
E

CamSchnapper wireframe off crash will be fixed in 2016.3140+. Thanks for the report.

On instancing

I think it is possible to install NVIDIA own driver, would this fix the issue with instancing

This is so exciting! However I get a crash on startup on my mac of the 099 experimental build :frowning:

It’s a Mac Pro with Nvidia GTX 660, running OSX 10.11.6 .

Crash log here, seems to be openCV related?

pastebin.com/q4F4C2Xb

Similar Problem here. I also tried the older builds but I’m getting the same error.

pastebin.com/cZfkbXmX

MacBook Pro, 16 GB RAM, SSD, NVIDIA GeForce 320M 256 MB

cheers

Benny

Might be an issue with the graphic memory as well?
derivative.ca/wiki099/index.php? … Video_Card

benny

Thanks for the crash logs, we are looking at it and may have found something. We’ll get back to when there is a new build to try.

Not sure if this is a macOS issue, or my TD issue…

I’m not having any luck getting a video feed form an external USB2.0 camera from a VideoDeviceInTOP. The device is being recognized, and is selectable. No errors, just getting a black output. On the TOP, I’ve tried changing output resolution and aspect ratio at every imaginable configuration.

When I deactivate the TOP, and open Quicktime or Photobooth, the camera source is there, and i’m getting a clean input at 1280x720.

Camera below:

https://www.amazon.com/ELP-2-8-12mm-Varifocal-2-0megapixel-Android/dp/B00SPBWM0M

TD v2017.7500
Mac Pro / OS 10.11.6 /AMD FirePro D300 2048 MB

Most cameras I have tried in macOS work right away. Wondering if this camera is unique and not using the standard AVFoundation library we use on macOS. Do you have another Mac (or a friends) to try it on? Wondering if 10.11.6 is an issue, though I doubt it. I would also check if there separate drivers available from the manufacturer.

Hi, I’ve downloaded the final v099 release for Mac, but still have the same crash as before. Anyone else had more luck?

Hi Matte,
Could you send us the crash reports macOS creates and let us know the specifications of your mac? You can find the crash reports via ​Applications->Utilities->Console. The Crash reports will be under User Reports and named TouchDesigner099_date-xxx.crash.

We can take a look at your crash and hopefully find the cause! You can email them to support@derivative.ca
Thanks

Edit: I see you sent us some crash logs back in March, but since 099 has changed so much since then and you still have the crash we’d like to look at the current crash logs. thx again

Hello,
I am having a strange lighting behavior on MacOs Touchdesigner version.
I loaded the attached .toe on MacOS and on Windows10 on the same computer, you can see the results on these screen captures.

Any other Mac users experienced this ?


Touchdesigner 2017.11520
MacBook Pro - Intel Iris Graphics 550 - Os 10.12.5 / Windows 10
lightingbug Torus Sphere.toe (3.92 KB)
lightingbug 1.toe (5.23 KB)
lightingbug Torus Sphere.jpg
lightingBug1.jpg

This seems like a driver bug for that particular GPU on macOS. We’ll see if we can find a machine to reproduce the issue in the office.