macOS Driver bug in 10.15.7 - TD will not run on some GPUs

This is a general PSA, the latest security update for macOS 10.15 which is 10.15.7 has a newly introduced driver bug that will keep TouchDesigner from starting. If you are on 10.15, we recommend updating to macOS 11 to run TouchDesigner with all security updates.

The other option is not updating to 10.15.7 but that means not applying a security update which we can not recommend.

We have reported the bug to Apple but as 10.15 is an old OS now and only getting security updates, we do not foresee them rolling out a fix any time soon.

P.S. So far all reports seem to come from older Intel HD4000 GPUs, if you have this problem we’d love to hear your system specs.