moviefileoutTOP video export fails, when Python expression in use

Hello, I encountered a problem with a moviefileoutTOP, that worked in an older
project (couple of weeks ago), probably with the previous version.

There is an error message “Unable to open output file”

I am using an f-string in Python to customize the output file name.
If I reset the parameter it works.
But the python expression does not work anymore.
It worked for half a year in the past.
Maybe it’s a regression bug in the latest Touchdesigner, I am using 22 33910

Expected: moviefileoutTOP custom output filename using variables in f-strings
work
Actual: File output fails completely

Example Python Expression:

f'{project.name.split(".")[0]}_{op("global_basename").text}_v{int(project.name.split(".")[1]):04}_{op("global_date").text}_cam01' + me.fileSuffix

I’m writing a video file mov / mp4 (not images or an image sequence).
It worked with local output (C: or D: drive on Windows) and also to a network share in the past.
Maybe the 1 thing that changed is going from Windows 10 to Windows 11, because of a new machine.

Resetting the parameter works, but I have a bad, unrecognizable file name.

Best regards, Martin

Thanks for the report. Can you post your .toe file? I’ve tried to reproduce this but had no luck so far.

Hey I got the same problem here.

Worked for some time an then suddenly stopped working out of nowhere.

I can export via constant into the exact same folder, but with an expression it wont.

HIMYMFrames.9.toe (5.8 KB)

Okay here is what I found out:

Using: 'D:/Output/' + op('select1').text + '.jpg' actually gives me a line break like so:

D:/Output/s1e8.mkv
.jpg

So instead I used a convert DAT

image
image

to split at the dot and used the following expression:
'D:/Output/' + op('convert1')[0,0] + '.jpg'

and was pleased with no linebreak like so: D:/Output/s1e8.jpg