Nexmosphere serial data error


I’m really not sure if this is a TD bug or human error. I’m trying to setup communication with a Nexmosphere sensor but I’m unable to get the correct data from it. I have all the settings correct and I am getting (bad) data from it, so communication is happening. I’m able to connect to it without issue using cool term.

Mac OS 13.1
TD 2022.32120
Nexmosphere XN-135M3

See screenshot below where I attempt to receive the same data, but TD isn’t receiving correctly. It seems like a baud rate error but I have them set the same.

Hm. The XR… X00… etc on the right is what is being sent to the device from you?
It’s usually the case where only 1 application can communicate through a serial device at a time. Can you try again without the secondary monitoring program?
If you want to send the device commands, you’ll have to do it through TouchDesigner.

Another small issue. The Row/Callback Format should be sent do One Per Line as it looks the protocol ends messages with CR/LF.


Thanks for the response! Sorry, I should have been more clear. Yes, the data on the right is what I’m expecting to receive. Right now I’m just trying to receive from the device. For context I have an RFID sensor hooked up, the XR messages include which port the data is on and if the tag was picked up (PU) or put back (PB). X0 messages include the tag id and state of that tag (0-1).

I was disconnecting from the opposite connection when testing, this is the only way it works, which is expected. It’s not receiving the CR/LF as that option wasn’t working, after a bit it would show a warning that data wasn’t being displayed because it didn’t receive the delimiter.

For this test I put a tag in range and took it out of range 2x, data on right worked as expected, data in TD is useless. I did try setting cool term to an incorrect baudrate and it displayed similarly incorrect data which is why I’m thinking it’s related to the baudrate, could TD be using the wrong one? I also tried a version of TD from 2021 and saw the same issue.

I’m going to test with an Arduino today, but I’ve used them extensively and have never seen this issue, maybe I’ve just never tried an 115200 baudrate.

It’s also my understanding that with USB serial port emulation, the baud rate is ignored as the communication can happen at full USB transfer speeds, but in your case it does seem to affect things when set incorrectly in cool term.
Nexmosphere doesn’t seem to have a way to change the default baud rate either.

For your arduino test, you are going to test serial communication between arduino and TouchDesigner at 115200 without the Nexmospheres? Please post your results.

Alternatively, do you have access at all to a windows PC or laptop to test this?
I’ve done a cursory search of the macos serial implementation and don’t see anything unusual at this point.

Thanks for the info.

Works flawlessly in Windows!

Let me know if I can provide any more information to help track this down for MacOS.

Ah. excellent clue!
I’ll log this for a closer look.