Nvidia Discrete GPU Not Working Correctly With TD

Hello TouchDesigner Community,

I am a newbie who recently jumped from the Mac world to a PC. I recently invested in the following laptop

Asus Zephyrus Duo
Intel® Core ™ i7-10875H @ 2.3GHz
Nvidia GeForce RTX 2070 Super with Max-Q Design
32 Gig of Ram

The laptop performs well when using other programs and gaming. However, when I use the laptop to work on Touchdesigner, GPU usage refuses to go above 10% causing the frame rate to drop into the single digits.

I have turned off Optimus and have played with the preset performance settings. All the latest drivers have been installed, and I am still having performance issues.

The laptop has a built-in second monitor that works like any other external monitor. After searching through the forums, I am assuming this could be the issue. But, I am not sure how I would go about fixing it. Bloatware or a specific program could be to blame too based on what I have read.

Any recommendations?

Thank you so much.

On windows, one consideration is to check your power consumption settings. Windows will sometimes throttle hardware usage if you’re on battery power only to conserve power. This is called your Power Plan - and you can find it in the settings menus, or in the control panel.

Next check the NVIDIA Control panel - here you should be able to set applications to use the dedicated GPU:

image

Next I’d check to see if the canvas is extending onto the second screen - if it is, add a monitor DAT to check which GPU your displays are assigned to. Id’ then experiment with moving the TD Canvas off of the second display to see if that makes a performance difference.

Those are the places I’d start… there’s lots more you can do to trouble shoot, but those are reasonable first steps. :slight_smile:

Thank you for responding. I tried all of that and no significant improvement. Updated drivers, tried disabling the screen, played with Nvidia Control panel and the power settings, and no real improvements.

When I added the monitor DAT, it displayed Nvidia GeForce RTX 2070 Super with Max-Q Design for both screens.

The screen works like any other secondary monitor. However, I can not figure out why TD is using such a small fraction of the GPU.

I feel it might be a simple fix and I am overlooking it.

I know this sounds silly - but are the results the same if you’re connected to power? I know some times folks see different performance if they’re plugged in to their adapter, or not plugged in.

No worries, I tried that in all the appropriate settings. Asus gives me full control of all of its battery modes. I have tried performance and turbo mode plugged in and nothing has changed. :confused:

@Alexandr1990

Did you had any luck yet? I’m having the same issue with my new Razer Blade 14 (RTX 3070). My internal laptop monitor seems to only use the AMD intergrated graphics in Touchdesigner, and I have tried Nvidea and windows graphic adaptor settings, with no luck. Which is strange because all the games can be played normally on my laptop screen, where I wonder if the issue should be solved within Touchdesigner’s settings/code itself.

Hey! So I did figure this out. It was a simple fix and rather silly. I have the Nvidia GeForce Now app installed in my laptop. In the settings it allows you to set the FPS. For some reason, the preset settings was capped at 30FPS. As soon as I toggled those settings up to 60FPS, I didn’t have that problem at all. Hope that helps.

@Alexandr1990

Hey, did you mean the geforce experience app? Because I think geforce now is only a cloud gaming app right? I’ve tried adding Touchdesigner to the Geforce experience app, but this didn’t seem to work, as It doesn’t recognizes it when scanning.

So when I’m using Touchdesigner only on my internal laptop monitor, or only on my second monitor, it all works fine. But whenever I want to use touchdesigner on my laptop screen and a perform window on my second monitor or vice versa, it all goes down and it’s start using the processor intergrated graphics again.