NVIDIA Flex- tutorials, .toes, tips

Since 2019.10000 series ships with CUDA 9.2, but Flex requires CUDA 8.0, you need to have the cuda 8.0 .dlls next to the Flex .dlls as well.

Thanks for info ,I’ll look into that.

after an other attempt

Can someone make a tutorial about this?

I’m sure its clear enough for visual studio gurus or other Glsl prophets, but the common man maybe not.

Because at the moment its like making a puzzle with 1/2 parts missing. One of the coolest thing you can do in TD and we cannot work it out!

There is no plugin folder in touch designer99, at least mine doesn’t !

got back a normal computer! youpi
so reinstalled everything fresh.

Why macintosh sold so many computers? they made it user friendly!

The strange thing is; I still get a message ‘’ this operator requires a Commercial or pro License. despite installing latest version.
I figured the plugin folder is the Sample/cplusplus/chop.
cuda 8.1 is installed…

sorry quite confusing, got 2 computers with 2 touch designer an 88 and 99 version, dll failed to load or requires com or pro. I did copy all these files in ; C:\Program Files\Derivative\TouchDesigner088\Samples\CPlusPlus\CHOP. one pc is laptop the other has windows 7 but good geforce at the moment, not working with either. maybe I’m just really unlucky, I realise that. at least you get feedback from user point of view. probably this windows 7 is to blame

Vinz, in your patch is there a way to readily change the geometry of the collision planes. For example making the planes with a higher poly count like a sphere. I see the calc_planes_equations Base, but I have no idea whats going on inside.

@greenpattern sorry you’re having so much trouble, will look more into the new experimental build at some point though it worked nicely in my test, otherwise a lot of people got it to work with the older production 099 build and a commercial license!

@Rumzie the github plugin I released only supports simple geometry collisions, planes defined by their equation (that’s what the calc_planes_equation does, using the planes normals and position), spheres defined by their radius and position, and boxes.

The flex api also supports triangle mesh collisions but it’s not implemented in the github plugin.

C++ operators required a Commercial or Pro license to run Official and older builds of TouchDesigner. If you update to our latest experimental builds (2019.10000 series), then you can use C++ operators with a Non-Commercial license.

Experimental Builds

It’s not true,
Simply recompile the project by changing the dependencies by selecting the installed CUDA version and changing the path in the project properties from CUDA_PATH_8.0 to CUDA_PATH.
I have the CUDA 10 version, I have modified and recompiled and it works correctly.

Hello all,
I was wondering if you guys could make it work without commercial licence. I’ve tried so hard, search on many sites i found and still got that error “failed to load dll”. Maybe is the Dll’s directory that is wrong? or commercial licence? I’ve been struggle this for days.
Any help would be more then welcome.

Recompiling the FlexCHOP.dll with CUDA 10.0 won’t change the the dependency that the NvFlexReleaseCUDA_x64.dll binary has on cudart64_80.dll. If this is loading, then that .dll must be on your system somewhere for it to find.

That error isn’t license related. It most likely means a required .dll dependency isn’t found.

Also it seems like the newest Flex release from Nvidia’s github repo has the .dlls compiled against 9.2, which is what the 2019.10000 series of builds is compiled against. So if you can get those (I can’t share due to EULA you need to sign with Nvidia), that may make the process simpler.

Hi, thanks for the reply.
Is there any chance you can share the link?
Also, i tried with the dll’s @vinz99 released on GitHub and still not work.
I dont know what else i can do to make it work :frowning:

These libraries are on Nvidias gameworks site:

You likely need to be granted access to it via making a developer login on Nvidia’s site, and accepting their EULA for these libraries.

Alright, with your help i was able to make the error disapear (“failed to load .dll’s”).
But now, whenever i Press R in perform mode or put the timeline to frame 0, the software stop working.
Also, i cant see the simulation working yet.
Any tip?

If you upgraded to the new Flex version it’s very likely you need to recompile with the new headers.

Hi guys thx for help, I totally forgot about this post.
All this made me think, as a visual artist, I need it to be visual.
messing with code as powerfull as it is , to me its a bit like a blind man trying to take a picture.
looses the essence for me at least, I’m gonna try Notch for a bit as it seems to be a bit more what I am after. I do think Notch has sort ripped loads of cool stuff for Touch designer.

Its sunny out there, I’m just no ready for this level of in depth. time required

I’m sure some people can think in code, depends of your built in human computer.

thx for all help, best of luck!


Just wanted to post a reply for others who may be trying to get this to work. If you go to developer.nvidia.com/flex and click the Download button in the upper right you will get a zip file called flex-110.zip. Extract that and go to flex>bin>win64. From there copy these files: cudart64_80.dll, NvFlexDeviceRelease_x64.dll, NvFlexExtReleaseCUDA_x64.dll, and NvFlexReleaseCUDA_x64.dll to Program Files>Derivative>TouchDesigner099>bin. This worked for me with out needing to recompile anything. I’m sure there may be some advantages to recompiling to work with CUDA 9.2 but this is probably the fastest way to get up and running. Hope that helps.


Hi Thanks for the info on Flex in TD.

I have some simulations with fluid particles working, but I’m wondering how I can skin/mesh them to make a solid fluid body.

Would there be a way non GLSL or is GLSL the only way?
This is for a project I’m working on now and its a bit ugent.