Oculus Rift TOP Texture creation error

Hi all,

I’m on Windows 10 (Pro, version 1909), two NVIDIA GeForce GTX 1080 Ti, Touch 2020.20625 (Non-Commercial), and an Oculus Rift S. I’m on the latest NVIDIA driver, 445.75 from 3/23/2020.

I have no problem with the Rift CHOP, which reports orientation channels without issue.

The Oculus Rift TOP however, in a clean project or any of the VR examples, always errors out with “Error: Oculus SDK failed to create textures for display.”

Any ideas what could be going on here? Is it that I’m on a Rift S? Is it non-commercial?

Thank you!

The Oculus Rift TOP should work with any license, though there will be resolution restrictions in non-commercial. Using a Rift S shouldn’t be a problem – I tested with a Rift S on 2020.20625 without trouble.

The error means the call to the Oculus API to create the OpenGL textures for rendering purposes failed. Perhaps there’s a bug with that Nvidia driver, or a problem with your dual-GPU setup. We also did upgrade the SDK recently, so I’d also recommend trying an older version of TouchDesigner to see if that works. The last build with the old Oculus SDK was 2019.36500. You can download that here:

https://derivative.ca/download/experimental

The error is a bit vague however, so I’ll append it with the error message from the Oculus SDK to get some extra helpful info.

Thanks for the quick reply Eric. I’ve just downloaded that build. Unfortunately, I’m getting the same error. When I plug a top into either output, my FPS slows down from 60 to 6 and the error comes up.

When you say append it with the error message from the SDK - is that something I can provide for you? How can I see that error?

Any info on how to hunt this down much appreciated. Also, I’m a Pixar employee and I asked about this in our Slack, and they mentioned we have a support line. If it’s easier for me to go through that channel, I can do that. Thank you!

No this is something I’ve added to that error message.

If you contact us at support@derivative.ca I can send you a build with that addition so you can see the specific error the SDK reports.

Thank you so much! Just sent a mail.

eric.b coming through!

Even though my GPUs did not have SLI enabled, I tried disabling one of them in device manager. I left the one enabled that had the Rift and one of my monitors plugged in. This worked and I stopped getting the error in Touch.

But, I didn’t want to have to disable one GPU (which I use for rendering in other apps) every time I used Touch. I ended up swapping my monitor cables (plugged each into the GPU they were not previously plugged into), and then going to NVIDIA settings and adding a special entry for Touch with the settings described in this post:

Nvidia Control Panel -> manage 3d settings -> select TouchDesigner ->

Change CUDA to the GPU with my main monitor plugged in
OPENGL to the same GPU
Power to “Prefer Maximum Performance”

Voila!

1 Like