OpenGL 1.x error on Nvidia Quadro P620

I have bought a Lenovo P330 Tiny with an i5 CPU and Intel Integrated Graphics UHD 630 and a Nvidia Quadro P620 to run an installation.

When I try to run TouchDesigner (build 2020.25380) or TouchPlayer, I receive the following error.

" Unsupported Graphics Configuration
OpenGL is reporting on version 1.x is available.
This likely means that the graphics driver isn’t correctly installed on this machine."

I have experimented with setting the Windows Graphics Settings to opening TouchDesigner, TouchPlayer and TouchEngine with the UHD 630 GPU and it actually works and runs fine at 60fps. If set the Quadro GPU as the preferred GPU for the three applications, I receive the error above.

I have naturally updated the Quadro driver to the newest version directly from Nvidia (ver. 452.06 DCH), as well as everything else via Windows Update and Lenovo Vantage without any luck.

TD’s role in this installation is to process some very simple sensor data that it receives via serial. This data affects a number of 256x256 TOPs with simple visuals. These are sampled and light data is output via Artnet to 8 washlight fixtures. Additionally a render network allows for a preview of the structure being lit up using Light Components.

Do you have any idea what I can do to make TouchDesigner run on the Quadro GPU?


Hey, can you try this build and send a screenshot of what the error you get is? I’ve changed the dialog a bit to give more information

Ah! I have a very similar issue! I have been discussing the problem with the support team and together we have got absolutely nowhere!

I am running the following;

Operating System
Windows 10 Pro 64-bit
Intel Core i7 10700K @ 3.80GHz 29 °C
Comet Lake 14nm Technology
16.0GB Dual-Channel Unknown @ 1499MHz (16-20-20-38)
ASUS VP28U (3840x2160@59Hz)
PHL 273V5 (1920x1080@59Hz)
Intel UHD Graphics 630 (ASUStek Computer Inc)
4095MB NVIDIA Quadro P1000 (NVIDIA) 31 °C
ForceWare version: 426.02
SLI Disabled
1863GB Seagate ST2000DM008-2FR102 (SATA (SSD)) 36 °C
931GB Samsung SSD 970 EVO Plus 1TB (Unknown (SSD))
Optical Drives
No optical disk drives detected
High Definition Audio Device

Intel UHD Graphics 630
Manufacturer Intel
Model UHD Graphics 630
Device ID 8086-9BC5
Revision 6
Subvendor ASUStek Computer Inc (1043)
Current Performance Level Level 0
Driver version
Count of performance levels : 1
Level 1 - “Perf Level 0”
NVIDIA Quadro P1000
Manufacturer NVIDIA
Model Quadro P1000
Device ID 10DE-1CB1
Revision A2
Subvendor NVIDIA (10DE)
Current Performance Level Level 0
Bus Interface PCI Express x16
Temperature 31 °C
Driver version
BIOS Version 86.07.6d.00.01
Memory 4095 MB
Count of performance levels : 1
Level 1 - “Perf Level 0”

After diving deep into the Google Rabbit Hole I have learned that the issue may have something to do with OEM settings! Apparently 3D Settings are pre-configured and locked out, therefore they cannot be changed. This is an issue with TouchDesigner as it appears to require these settings to be altered in someway. How I have yet to determine.

I have passed on this information to (builders of fine PCs) to see if they have an answer that may shed some light on the problem. For now though the only solution I can see is to get a retain GeForce card and install that.

N.B My home PC is of a similar spec but has dual Nvidia GeForce GTX 1060’s

Are you able to try the build posted above and print what the error says? We don’t require any particular 3D settings that I know of, but if the driver behavior has been altered in a particular way it’s possible that’s why it’s not giving us access to the GPU.

Hi Malcolm,

I’ve tried running the build you sent, and it returns the following error:


Thanks, Christian

This is a strange error. I hope there is some way to resolve it. I am starting to feel stupid for spending money on an external graphics card, considering that the project actually runs fine on the integrated GPU. It doesn’t help if I can’t even pretend that the Quadro GPU performs a little bit better. :neutral_face:

So that error is telling us that we aren’t even being given either of the actual GPUs by the OS. The OS is giving us the software fallback renderer, which isn’t really useful. The way OpenGL works is we can’t really say ‘give us X gpu’, we just ask for a GPU and the OS gives us whatever the driver is configured to do. This usually occurs over remote-desktop or virtualization situations, so I’m confused how it’s happening on this case. It definitely a driver issue somehow, but hard to say what.

Well that does in fact explain something!

I am currently accessing the computer remotely via VNC because it is already installed on-site, and I am back in the office.
I had a vague idea that the program ran correct the first time I tried, but since it was installed in a stressful situation, I wasn’t sure whether it did in fact ever run on the Quadro GPU, and assumed it didn’t . After the initial installation I started accessing the computer remotely, because the computer is mounted inside a crane.

What VNC tool are you using? Some work with GPU acceleration, some don’t. The dameware one works I’m pretty sure.

We are using RealVNC.

But isn’t there a way to start the program timed or remotely on the GPU? The system is not headless. At least not at this point. Or put in another way, what determines whether the you can or cannot access the GPU is this scenario?

The VNC connection is essentially it’s own shell into the OS. So its one that has limits vs a native login. It’s not just a screen capture.

Didn’t get any notifications of replies sorry, been busty at the office. I have heard back from Scan who suggested moving the display cable to the onboard card, which it already is, so that didn’t work, however I will install and run that version tonight, we have a test projection planned from the community centre. I will also remove the Quadro and see if that fixes the issue! Never thought of that! If that fixes the issue then I feel i may be right about the Nvidia drivers. We will see and I will continue to update…

Installed the new version with additional information but nothing brought to light. I will now disable the Nvidia card and see what happens!

I went in to Device Manager and simply disabled the Nvidia card. Started the application and it works. I will now run performance tests to see if there is any noticeable impact. Naturally I will need to enable the Nvidia for my prototyping work but this will suffice for now. I still believe the OEM drivers are to blame and would be interested in trying the retail version of the drivers to see if that affects anything.

Thanks for everyone’s help getting me thus far.

Hi there! I had the same problem but resolved it! I’m using an ASUS ProArt Studiobook laptop with a NIVIDIA Quadro RTX3000 and an intel cor i7 9th Gen.
I was surprised to see others who have this problem because this is the first time Touch Designer has ever given me an issue.

My solution was to completely uninstall and reinstall my NIVIDIA driver (windows key + x) via the device manager.
Here’s their index page for the latest drivers:

Hope this helps!

I’m returning to this thread to document the solution I found for my problem. It turns out I had committed a slightly embarrassing mistake and connected the screen to the wrong port on the PC. On the Thinkstation P330, the HDMI port is connected to the internal graphics card. You need to connect the screen to one of the Mini Display Ports to get to the Quadro card.

After moving the screen to the correct port, I had no trouble getting Touchdesigner to run on the right GPU. Afterwards I have used the built-in tool to save the screen EDID and load it from file, and I have disconnected the screen so the system is now running headless. I am able to access and maintain the system via RealVNC.

I concur, we invested in some new DVI cables and connected directly to the NVidia card and set that monitor as the primary monitor, the issue is no longer present.

I am having a similar issue. This is on an Intel NUC with Intel GFX card. The project launches when the system is booted ok. Also if connected with RDC the project launches.
But if RDC is not connected, when the project is launched with Task Scheduler or by project.load() from within the project, I get the error “OpenGL is reporting only version 1.x is available. This likely means that the graphics driver isn’t correctly installed on this machine.”

+1 - I’ve seen this behaviour as well, would love to know what it could be.

It’s a Windows behavior, something to do with remote sessions and/or console applications… Our process is being started in a situation where there is no GPU exposed to it. It is strange that a TD process that is working would launch another one via project.load() that isn’t in the same space that has access to a GPU though