Opening OP Create dialog

Hi

I have trouble with opening sub-menu windows. As I double click to open OP Create dialog, the main window switches with the new window. I’ve updated the graphic card but there is still the same problem.

I’ll be grateful in advance!

Hi @Sararahmani,
I am not sure what you mean by “window switches with new window”. Perhaps a short screen-recording of the problem would help us understand.

Does it also happen if you use the Right-click menu and select “Add Operator” or use the keyboard shortcut key for opening the OP Create dialog.

I can honestly say I’ve never seen that before.
Could you give us the specs of your system?
Most important is the Operating System, GPU model and GPU driver version you are using, but any information additional information is helpful.

Also which build are you using, the title bar is cut off so we can’t identify and there is an update available so we’d like to know which build you are running.
Thanks

I’ve installed the older version and there is no problem anymore.
Thank you

Could you tell us which build you had to go back to, and what your Operating system and GPU are?

Thanks

Sure. 2019.20140, windows 10 64-bit, Radeon R9 M280X - 4GB

1 Like

@Sararahmani Just cam across a slightly different issue but it might also be causing your problem. Other people are reporting a empty or black OP Create Dialog so perhaps this fix will help you as well.

Can you go into Preferences > TOPs > Global Resolution Mulitplier and set it to “1X” and then click Save?

I did so but I can’t save it, however, 2019.20140 build works properly on my laptop. Do you suggest to install the latest build and try again?


Thank you for being supportive

Yes, setting the global resolution multiplier to 1X and pressing Save should fix it in the latest build we have posted.
We are also working on a fix for the new build so it doesn’t happen any more.

I even couldn’t press Tops.

This looks like a different problem actually. More like graphic drivers, have you gotten the latest drivers from AMD.com?
You could try 2 things

  • If you have any Windows Display Scaling, turn it off and back to 100%
  • Close TouchDesigner, delete the preferences file and restart TouchDesigner. That file is located here: C:/Users/ username /AppData/Local/Derivative/TouchDesigner/pref.txt

Yes, cause at first I thought so. I’ve checked Display settings and it is exactly 100%. Deleting pref.txt couldn’t help.

Thanks for your help.

Is it a laptop? Many laptops come with bloatware that can cause strange problems (search for ‘bloatware’ in this forum). ASUS, MSI, ACER have some programs preinstalled that are troublesome.

Yes, it is a laptop. I’ve uninstalled bloatware and nothing has changed.

@Sararahmani We are trying to reproduce this issue. Can you report to use which version of AMD drivers you have installed?

1 Like

Sure.

10.0.18362.693

Unfortunately that is a Windows version number, not the driver version numbers that AMD uses.

For the Radeon R9 M280X GPU the latest driver is version 20.5.1 which you can download here.
https://www.amd.com/en/support/graphics/amd-radeon-r9-series/amd-radeon-r9-200-series/amd-radeon-r9-280x

Or the AMD Catalyst control panel should give you the AMD driver version, but I would recommend installing the drive I linked to above as it was just release May 27th.