Opens to Blank Screen on Laptop

Hey folks,

I am having a problem installing TD on my laptop. Everything appears to install correctly, but when i open the program i get a blank black screen as well as a smaller blank black window that would be for my key manager.

I have Uninstalled/ Re installed mutiple times
I have tried installing a previous build and still the same issue.
I have tried opeing the .exe file from my program files.
I have updated my Graphics card.

On the Laptop I am running:
Windows 10 Home 64 bit
NVIDIA Geoforce GTX 1060
Intel Core i7-7700HQ CPU 2.8Ghz
16 gb Memory

Everything works perfectly on My desktop but I would really like to be able to get it working to I can continue to learn while Im on the road. I am still very new to TD, But having a great time learning this fantastic program. Any help would be appreciated.

It sounds like a graphics driver issue. I would try uninstalling and reinstalling the nvidia drivers. Make sure you download the graphics drivers from, do not reply on Windows or the manufacturer for up to date drivers.

It sucks but use an external monitor. I bet it will fix your problem. I run into the same issue.

Are you using a p51 laptop with external graphics card? My best guess as to why this happens is the laptop screen runs of an on board graphics processor. The external displays HAVE to run through the external graphics card.

If you find a fix, please let me know.

Hello, I just had a similar experience with a brand new MSI with Nvidia GTX 1070, after ten days fighting against the blank screen crash in TD but also DaVinci Resolve ans Isadora, my solution was to eliminate all the non necessary drivers and bloatware installed by MSI. The main inconvenient is provoked by the Nahimic sound driver. I was not able to uninstall it entirely, so I sometimes run this batch (with administrator privileges):

echo on
title LIVE setup: spring cleaning
echo echo Live SETUP
echo Killing nasty processes
taskkill /f /im “NahimicService.exe”
taskkill /f /im “NahimicSvc32.exe”
taskkill /f /im “NahimicSvc64.exe”
taskkill /f /im “MSIService.exe”
taskkill /f /im “AGSService.exe”
taskkill /f /im “ShareX.exe”

Since then I just finished a show with 5 HD screens (3 on matrox DP, 1 on Hdmi, 1 on thunderbolt 3), no crash, 1 million particles at 60 fps and all going very well.

Hope that helps,

So I have updated the NVIDIA drivers directly from them and still nothing but it DOES work when I use an external screen!! This Must mean that ahlynsky you are correct. An external screen is forcing the laptop to just use the Graphics card. On the laptop its a blank window but when i drag it to the external monitor it populates with the program. crazy. working on a fix now. will keep you updated.



So I was able to Fix my problem. Here is a step by step of what I did.

  1. Open the Nvidia control panel
  2. Go to Manage 3d settings

( many help forums will say at this point to go into global settings and change your “preffered graphics processor” from “integrated” to “high performance GPC” HOWEVER, this option was not avaialbe to me on my lap top.

  1. click on Program settings tab.
  2. next to select program to customize hit “add” Derivative Touch Designer and hit add selected program
  3. Now this will give you options to specify setting for this program in the box below.
    7.I clicked through every feature setting and changed it from its Global setting to just the nividia setting. when selected the text appears in bold.
  4. APPY changes
  5. Restart laptop.
  6. BOOM!!! It works.

Hope this helps anyone who was as frustrated as me going through this for the last few days.

Happy Hunting! :smiley: :smiley: :smiley:


Was going crazy on my MSI GS65. Every time i was clicking “Open” on external screen in a Window comp, blank output, freeze, crash.

I had tried all the steps myself, except step 7 which solved everything.

Should be pinned somewhere for all Optimus/MaxQ users to see!


1 Like

Dude you’re a fucking legend, thanks <3