OSC not having it

Been trying to use Touch OSC on my iphone with TD on my PC all day. It’s syncing to the OSC layout editor. I’ve also tried turning off my firewall and have Touch bridge open.

Any ideas?

Hi @volumetricvisions - I usually start trouble shooting these pieces by seeing if I can isolate a few variables.

You might first check to make sure you can communicate via osc inside of touch itself. That seems like a silly step, but it’s worth checking to make sure that TD can talk to TD as a starting point.

Check all your settings - are you talking to the right device on the right port. OSC is destination based so TouchOSC will need to know the ip and port to target on TD.

Next up you might try to see if you can ping your mobile device. The ping command works in your OS terminal, that will tell you if your devices are able to communicate with one another.

Make sure both devices are on the same network - again it seems obvious, but it’s always the little things that will get you… or at least, it’s the little things that have always bitten me when I’ve least expected it.

Next, check your router - some routers are set-up to block UPD traffic. If you have a wireless router that was provided by your internet provider you might need to do some additional configuration work.

Sometimes renewing your connection - forgetting and adding your network back on your mobile device - helps shake off any oddities.

Similarly, sometimes giving your devices a re-start is worth doing… I wish that this didn’t fix issues, but sometimes the old turn it off and turn it back on again does the trick.

Last but not least you could use a tool like WireShark (https://www.wireshark.org/) to snoop network traffic and confirm that you are indeed both sending and receiving messages.

Those would be the steps I’d take… hopefully somewhere in there things get ironed out :smile:

1 Like

Hey thank you for your in depth response!

So I’ve tried it with Unreal Engine and it is sending a signal to that. I’ve tried different ports.

I’m not too sure how to ping? I tried from the computer running a command promp and got this

But I don’t know a lot about code so I don’t know what it is I’m looking for exactly haha.

Do you reckon it could be that my router is blocking it if it is working in Unreal Engine?

Those results mean that you can talk to the device - which is great.

If it’s working in Unreal, then I’d guess there are some other squirrels at play here.

Do you have Unreal running at the same time? As in, are you trying to talk to TD and Unreal simultaneously?

If you’re trying to do this :point_up: you’ll hit some problems unless you use a multicast address.

You might try removing your TD firewall rules, quitting and restarting TD. When TD restarts you’ll want to check both boxes for network communication.

No I’ve only opened the programs separately.

When you say removing the firewall did you mean this screen?

or is there a way of doing it within TD?

It’s in the advanced panel for your firewall in inbound and outbound rules:

You can select the rules for TD, delete, them, and then TD should ask you about them the next time you start the application.

Hmm TD wasn’t in there for some reason. I’ll try it on another computer and see what happens. Thank you so much for your help! :smiley:

I just have a problem with this. Can’t even hear himself :frowning:

What to do in this case?

1 Like

Same here!

I have OSC working perfectly on my windows desktop but now im trying to setup a second device (my windows laptop) following all the same steps and it all works 1 to 1.

You’ve mentioned multicast… I am trying to send OSC from iphone and recieve it on multiple computers/devices now simultaneously ? Does that requires a special setup?

I could create multiple OSC chop out nodes… one for EVERY IP but is there a way to spray OSC all over everyone on the network?

Using multicast does require some additional set-up.

I’d give the network protocols article a quick read:
https://docs.derivative.ca/Network_Protocols

You’ll notice there that you need to use a specific addressing for your multicast messaging.

You’ll also want to check your router / network set-up to make sure your traffic isn’t blocked.

1 Like

Thanks Matthew. I tried specifying the 224.0.0.0.0 address but its probably the router that is blocking me. I’m not really sure about router stuff how to log in and unblock ports… is there an easy guide for that (also feels dangerous)?

Is this iPhone on the local WiFi or remote?

If it’s all on the local network, you shouldn’t have to open ports. Some routers can disable communication between local clients, but most, by default, do not.

That’s not a typical local IP. Usually they’re something like 192.168.etc and aren’t usually zeroes. Also you have five parts (four periods) there, but usually there are only four parts to an IP4 address (xxx.xxx.xxx.xxx).

You might want to start a separate thread about your specific networking setup.

That network address (224.0.0.0) was set as one of the multicast ports from Network Protocols doc (see under multicast section). which are different than IP address on computers. These “special” addresses are supposed to broadcast OSC messages to ALL computers on your network with an open port number… this is a case where I am trying to send OSC from one computer to many receivers so I can’t just specify ONE IP.

I think what’s happening is my router or something is blocking the port number which is a problem with my router not touchdesigner per say…

Interesting. I’d skip that 224.0.0.0 address.

Doing a quick test, I’m seeing success with 239.255.0.10. Here’s what that set-up looks like for me:

You might also want to look up multi-casting behavior for your router, to see if there are any changes you need to make in your admin settings.