Particle GPU in 2022.24200 build

Hi! I have occured some troubles when apply the ParticlesGPU in 2022.24200 build, which is 2.0.2 version. We would like to give a mouse interation of Input Magnitude to collide with particles. It was works well in previous version 1.0.1, however, it is not allow to change any value in current version. It would be great if anyone have solved this before, and we would like to know how to make it happen! Thanks

From what I’ve seen, if it is inaccessible like that, Derivative/whomever has specifically made it non-accessible. I know they did confirm they did a big overhaul of the GPU particles component in the 2022 build, so might be best to download the old GPU particles and use it unless this truly is a bug.

Yes, somehow we would like to use the ParticleGPU in OS system, by playing with the mouse interaction. The ParticleGPU 1.0.1 could not run in the 2022.24200 build in OS, so we would like to ask help.

Hi @Jimmz,

still contemplating how to best redo the external input as we had it in the older particlesGpu version.

Perhaps the better way now is to use the Extra Force which can be difned via a CHOP in the “Extra Forces (CHOP)” parameter on the Forces page. The CHOP needs to contain 9 channels named:

  • forceposx
  • forceposy
  • forceposz
  • forceradius
  • forceamount
  • forcetype
  • forcedirx
  • forcediry
  • forcedirz

The forcetype channel can have the values 0 to 3 and enumerates the types:

  • radial
  • axial
  • vortex and
  • spiral

Might be worthwhile noting that the radial force does not make use of the forcedir* channels.

The exteranal, texture driven input will make a return in the next updated version of the component.


Thank you Markus, we will try how it works!

Hi Markus, We have tried and it works quite strightforward. However, there is a problem when we have multiple inputs of force CHOP. Imagine we have four forces as the inputs to interact with particle, if we reduce one of those force input, in the position of this faded forces it still interact with particle, regardless it is invaild. I made some screenshots to illustrate what I mean. Is there any way to improve this situation? Thank you for your supports!

Thank you Markus.

Hi @Jimmz,

ah - I didn’t catch this - the samplerBuffer size is not decreasing but only ever increasing. Added a workaround for this in the attached version. This will be updated in the next release as well.

particlesGpu.tox (484.9 KB)

1 Like

It is working well. Thank you Markus.