Possible to adjust the scroll speed of Container COMP scroll?

Hi there, I was wondering if there is anyway to adjust how much a container comp scrolls by with the mouse wheel. I am dealing with an issue where 1 scroll tick scrolls way too far in a container comp; it scrolls further than 1 full view and makes mouse wheel scrolling unusable since items get skipped over.

I tried searching around in the documentation and forums but didn’t find anything discussing this. Not sure if it’s related to my OS settings but the behavior is pretty consistent across machines. I can make an example file if needed.


There’s not currently a way to adjust that, but it is already in the RFE queue!

Word on this is that we won’t have the ability to adjust, but the speed was adjusted in the next release so it should be more usable.

Awesome, thanks @Ivan!

Are you using 26590?

Yes. From what I can tell the scroll speed feels the same from before the new builds.

Interesting. Can you post a toe or tox with your scrollable container? Or send to ivan@derivative.ca

Also, can you tell me your OS, system hardware, and mouse brand/model?

We’re trying to get to the bottom of this, especially since it should have been working better in the latest release.

Hey @Ivan, I was able to make an isolated example. In my actual project the over scroll is a bit more extreme, but I’m hoping this example replicates it enough.

From trying to recreate this, it seems like the over-scrolling starts to occur once I start nesting containers and doing layout with anchors. If I get rid of all the layout with anchors and just have the containers either have a static size or fill their parent the scroll seems ok.

over-scroll.toe (6.4 KB)

I am noticing the same behavior across 2 different Windows machines, one a desktop and one a laptop, with different hardware. I also have the same behavior with 2 different mice and my laptops touch pad.

My OS is Windows 10 Pro version 21H2
Processor is Intel 12th gen i9-1200K
GPU is EVGA 3070ti
Mouse is Logitech G502 and also a generic Microsoft mouse (seen here)

In my Windows settings mouse speed is set right in the middle of slow and fast.
Vertical scrolling is set at scrolling 3 lines at a time.

Let me know what other info I can give. Thanks!!

Yeah I’m seeing this. It scrolls a little bit too far each time. I’ll get this into the bug queue! Thanks for example!

Great! Thanks @Ivan !!