Problem with dropDownMenu widget in dual-monitor project

I’m using UI widgets for a project that is displayed across two screens. My setup is a single perform window that spans both monitors, set to fill without borders.

However, I’m unable to get the dropdown widget to display its menu in this setup. It works fine with a single monitor but with two, the menu does not appear on click.

I’m on a MacBook Pro, trying to display the UI on the laptop screen (primary, left-most monitor).

Any ideas how to get this working?

This file is a 100% repro for me:
DualMonitorDropdown.toe (25.9 KB)

Thanks!

Could you let us know the build number? I tried on Windows and it works, so it could be a macOS specific bug but would like to know all the details before spending more time trying to reproduce it.

Do you see the pop-up elsewhere on either monitor? I’m also wondering if it is opening behind the Perform Window or something like that. What is the monitor layout, 2 monitors of 1920x1080?

Build is 2021.13610
I simply don’t see the popup at all in this situation.
I’ve mostly tested with the MBP laptop screen (monitors DAT shows this as 1792x1120 when DPI scaled – DPI scale is 2) and a second screen positioned to the right of that, aligned along the bottom edge, 1920x1080 (DPI scale 1).
The example above repros for me. I also find the same when the primary monitor canvas is sized to exactly fit the laptop display res.

Thanks for looking into it!

@markwheeler Sorry for the delay here, lost track of this report.
I just retested your file in the latest 2021.15240 and it is now working. One thing you must do for spanning multiple monitors to work in macOS is go to Mission Control Preferences and turn OFF “Displays have separate spaces”. Once this is disabled and you logout/login, your example file works well, but before this setting change you’ll get no joy.

Can you update to 2021.15240? Let us know what you find.

Interesting. I’m testing with 2021.15240 now but seeing the same results as previously (rollover shows correctly, on click no popup appears). This is on macOS 11.6.1. I’ve never had the ‘Displays have separate Spaces’ option enabled.

I’m wondering what your exact monitor sizes are, what the arrangement is, and what size you set the project container to to get this working?

Edit: One additional data point I just noticed. If I click to trigger the dropdown, and then use the Mission Control gesture to show all windows, I can see the dropdown – it certainly seems like it is opening in the correct XY position but behind the perform window.

Thanks!

The reason I had to turn off Displays Have Separate Spaces is that a Window COMP will not span across multiple monitors unless that is off. That happens on both my Macs at least, 10.14 and 12.0.

It seems I got lucky in my first test, because I went back and tried a bunch more configurations and then the a couple of bugs appeared.

Bug1 as you reported, seems to always happen on the built-in laptop monitor, but when the dropdown is on the external monitor it works fine. This seems to be a bug with the Window COMP inside the Widgets not displaying the dropdown overlay on top. I recommend checking the menu on both monitors.

Bug2 if you set the built-in monitor to a custom display scaling like “More Space”, then the mouse click coordinates no longer are correctly aligned, they click into the panel with an offset.

Both of these bugs we’ll look at fixing, but in the meantime I did find a solution that works. If you use Custom Parameters and a Parameter COMP for UI, these gadgets work fine in all cases.
Check out the edited file, it has the Parameter COMP method and also I duplicated the panels to show up on both screens as this makes it easier to confirm if it is not working on both screens or just 1 screen as in my case.
DualMonitorDropdown.toe (45.3 KB)