Quest 2 questions

Has anyone had any luck interfacing with the Oculus Quest 2?

I have a Quest 2 headset connected via a link cable (USB 3.0) that I’m trying to get working with TD, and am seeing some strange behavior that I can’t explain.

I have a project that functions perfectly at 60fps (at 4K resolution), but when I connect to the Quest headset (using the stereo render setup in the Oculus Rift example projects) I see variable framerate that cycles unpredictably between 30-60fps. The results in choppy animation that makes the Quest unusable.

I’ve tried tuning the headset using the Oculus Debug Tool, but have not found any settings that appear to impact the performance. The performance monitor provided by the ODT reports that there’s approximately 20% performance headroom on the Quest itself. It also reports consistent dropped frames by TD.

The link cable has been checked and passes the Oculus tests (reports as 2.3Gbps).

My system specs:
Win10, TD version: 2021.16960
2080ti, nVidia Game Ready Driver v. 516.59
64GB RAM, i9-9900KS 4GHz

Hey @jesgilbert,

have you tried running the oculusRiftSimple component from the Palette>OculusRift section?
One thing of note there is the “High Performance Mode” which switches TouchDesigner into a Perform Window with the Window COMP having the “Draw Window” parameter disabled as well as the “V-Sync Mode” parameter set to disabled.

Another thing would be to check your Oculus Rift’s settings: what framerate is it updating with (and make sure to set TouchDesigner to the same framerate) and what are the resolution settings in the Oculus App.


Hey Markus, thanks for the reply.

The key was the v-sync setting. Once I disabled that and entered performance mode the frame rate was locked to the the Quest’s frame rate steadily, with plenty of performance overhead (40-50%).

I have the Quest running at 72fps, which is its native frame rate and gives the best resolution. I’ve set TD to the same, and it seems to all work as expected now. The OculusRift TOP does report an error, requesting that TD be set to 90fps - I believe this was required for the Rift to work. It would be nice if this went away, but I can certainly live with it as the system seems to be working now.

Hey @jesgilbert,

the warning you are mentionig will be removed with the next release.
Out of curiosity, what is your hardware setup? I find when even only briefly dipping under the 72fps, the quest seems to force touch into 36fps…


I did find this 1/2 rate behavior when editing the network, but when I switch into performance mode the frame rate is locked solidly at 72fps (also at 80Hz and 90Hz settings). The actual frame rate is clearly visible in the HUD performance monitor that can be accessed from the ODT.

1 Like