Quick question about light

Hello, I have a (total beginner) question :
In tutorials videos, the sops in geo comps appear in white, but on my computer they appear in dark grey.

For example if I create Geo, Light, Camera and Render, the picture in the Render Top is black.

I can light it if I change z translate on Light from 10 (default) to -10…
Is that a normal behavior?

Thank you!

TD version : 2017.10940 running on a MacBook Pro 2016 with Iris Graphics 550

It is possible that in the tutorial videos they were using a constantMAT (material) applied to the GEO which would cause the SOP object to emit light.

Thank you for your answer, I was asking about the light source in node viewers to monitor geometries before render, but I can’t find informations on the wiki.

For example if I create a single SOP sphere, there should be a “monitoring” light source in the viewer so I can see it. This light source should be outside the sphere, but on my computer the light is inside the sphere by default.

ie when I create a sphere sop, the sphere appears grey on the node viewer. Then if I zoom in enough to be inside the sphere it is lit up, like the light source is inside the sphere…

I was wandering if it could be a configuration problem of graphic card ?

Do you know what is the normal position of the default light source in the node viewer, and how to eventually change it ?

I can think of a few programming mistakes that could cause unexpected lighting results, or it could be a hardware/config issue, or a software bug… I’d rather not speculate too much without more info. It would help if you post a simple example file where you are having the problem and a screenshot so we can compare render results.

Have you been playing with any TouchDesigner preferences or still using default settings?

Hello,
Here is an example file, I just loaded a geo comp, no modifications.
The two pictures attached show how I see this geo on my computer. The first one is default view, and for the second picture I just zoomed in to go inside the torus to show the light inside (still no modifications).

So on my computer the outside of the torus is in the dark, and the inside is lit up… :question:

(I use default settings in touchdesigner, build 2017.11520 on macbook pro 2016 with integrated iris graphic 550)
Capture d’écran 2017-07-29 à 11.47.59.png
Capture d’écran 2017-07-29 à 11.47.39.png
light inside.toe (3.78 KB)

Hey, I have the same problem…
Did you solve this problem?

Sounds like your normals are messed up. Try turning “compute normals” on in the Torus. Or, add a point sop, click “add normal” and for normal x y z put a negative sign in front of them. This will reverse the normals.

This is a bug we’ve seen with some MacBooks, we have not been able to recreate it yet so we haven’t been able to fix it.
Everyone that see this please post your Mac hardware configuration.

Thanks

Hi same problem. Brand new macbook pro, making TD pretty unusable for my projects :frowning:

What I did notice is when i set the material “Polygon Back Faces” to backlit and it lights up properly the geometry appears to be inside out. See attachment.

Would love a fix or a workaround

many thanks

(My machine specs below)

OS 10.13.3
MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
Processor: 3.1 GHz Intel Core i5
Graphics card: Intel Iris Plus Graphics 650 1536 MB

TD 099 -build 2017 15960
instancing.5.toe (6 KB)

Same here.
3 identical macbook pro 13’ late 2016, running OX 10.12.6, Intel Iris Graphics 540, Intel Core i7 2.4 GHz.
Bought for a TD classroom, we can’t fully use them because of this bug.

hi ,
same problem with me, was there never a solution to this?

Im using this hardware
MacBook Pro (15-inch, 2016)
2.9 GHz Quad-Core Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 460 4 GB
Intel HD Graphics 530 1536 MB