Realsense support for MacOS

I’ve been working on a realsense project on MacOS. I’ve been building a custom python library, but I just learned that TouchDesigner supports realsense, which would be huge for me as it would save a lot of time and effort.

I have a D435 camera connected and I can confirm that it streams depth, infrared and rgb data via the latest version of realsense-viewer. However, when I create a Realsense TOP in TouchDesigner, I see no error message but no image data is streamed from the camera. This is regardless of which stream is selected (color, depth, aligned, etc).

So far I’ve tried:

  • Installing TouchDesigner on both a Macbook Pro running Monterey (the latest supported version) and on a Macbook Pro running Mojave (I haven’t upgraded this because the realsense SDK perhaps works better on this version of MacOS).
  • Using the most recent camera firmware.
  • Using the camera firmware that matches the realsense SDK version 2.50.0 used by touch designer.
  • Running TouchDesigner with sudo
  • Using this solution Installing realsense on the mac - #5 by trevorn1 to replace the .dylib file.

No matter which laptop/OS I use and which firmware version, I still get no streaming from the camera in TouchDesigner. When trying the solution shown in the forums (replacing the .dylib) I get a segfault when choosing the camera model in the TOP params.

Any thoughts on how I might proceed here? I know realsense support is generally waning but using TouchDesigner would be incredible because it supports just about everything I need for my project now and in the future.

Thanks!

1 Like

I am in the same boat - it seems to be the latest realsense library for macos is available and works properly (it can even be installed with brew!). When I examine the TOP in TD, it even shows the detected version of the library: “LibRealSense SDK version: 2.54.2” - but doesn’t shows any image.

The basic image + pointcloud even shows up in ANY MacOS application when I choose the RealSense camera (as a standard USB camera).

It seems to be only TD needs to be tweaked a little at this point to make it work well.

In the Derivative - User Guide MacOS page they say: “The [librealsense SDK v2.50.0] does not look like it will be updated for Apple Silicon, so it is not an option to add to these builds.”

Which is not true, its already updated and working on Apple Silicon (and TD itself can even recognize it - see above).

Please let me know if you found any solution(s).

I did recently upgrade our RealSense SDK to the latest version to hopefully fix this, although I havn’t had much luck myself getting it to work too. I’ll give it another look though