RESOLVED: 2021.10330 - Mouse In CHOP not working on High Sierra

I’m having an issue where the Mouse In CHOP has stopped working with the 2021 update on an older computer which is running macOS High Sierra 10.13.6. I know very few people probably run High Sierra at this point but I thought I would post anyway.

Basically, when I place the Mouse In CHOP into my network it doesn’t respond to mouse movement at all - both the default tx/ty values stay at zero. Adding channels for the mouse buttons doesn’t work either. Turning on/off performance mode, restarting TouchDesigner, deleting/recreating the CHOP, and restarting the computer don’t seem to have any effect.

I’ve tried downgrading to an older version of TouchDesigner (2020.26630) and found that it is working without issues.

I’m not sure if this issue is tied to this particular machine or to the High Sierra OS – I’ve also tried using the Mouse In CHOP with the 2021.10330 build on several other Macs with newer versions of macOS and haven’t run into any issues. Just thought it might be worth noting since I wasn’t having an issue with previous builds.

Let me know if you need any more info about my particular machine.

Hello,
Its not really a solution but it can helps you.
I avoid to use Mouse in Chop because its an OS value and not all the device are transmitting it. Its more secure to use a Container Comp, in active mode or played by a Window Comp to pass the info using Panel Chop. You can have the same info as with Mouse In Chop (just a little Math Chop to adjust the values).

1 Like

Thanks for the report!

We’ve had reports of this issue on and off but have never been able to reproduce. Both my machines have no issues although one is running Big Sur & the other one Mojave. The issue had always been machine dependent though, so it is interesting that the 2020.20000 builds work for you. 2021.10330 is based on the 2020.40000 series of experimental, so if you are up for installing a couple of older experimental builds from here I’d like to know if you have issues on those builds as well.

https://derivative.ca/download/experimental

Another node to try is the MultiTouch In DAT, toggle on Include Mouse. Does that work for you? Thanks for your help.

1 Like

@selina Thank you for the suggestion! The MultiTouch In DAT did work after all. I ended up solving the problem after going through and trying all of the 2020.40000 series builds – it wasn’t actually the build that was causing my problem, but instead the placement of the TouchDesigner application in my applications folder.

I had been placing the different versions of TouchDesigner I’d been testing into a folder within my applications folder so that I could keep the known-working 2020.26630 version separate in case I couldn’t get any newer/older versions working.

For whatever reason, I decided to try taking one of the 40000 series builds out of the folder and place it directly in the root of the applications folder, and it fixed the issue – the Mouse In CHOP is displaying the mouse position correctly again. I then tried the same with the latest 2021.10330 release and it appears to have solved the issue. I didn’t realize that the location of the application might make a difference. Thanks again for your help!

Also @jacqueshoepffner thank you for this tip! After reading your message I saw the same suggestion in one of Matthew Ragan’s videos - seems like a very useful technique.

Oh, that’s interesting. If I’m understanding you correctly, the mouse in CHOP worked when TD was installed under /Applications but not when it was installed in, say, /Applications/Test? I wasn’t able to reproduce it on Big Sur or Mojave, but I had run into a problem before where I got permission errors when a subapplication inside TouchDesigner wasn’t in exactly the right spot. I’m wondering if the folder location explains the issue previous users had, that’s certainly not something we had thought to ask.

For installing parallel builds on macOS, I generally add the build number to the TouchDesigner app name and I usually have several installed on a machine. macOS is definitely a bit easier than Windows for running parallel builds.

1 Like

Yes, that’s exactly it. I tried to replicate the issue on another Mac that’s running Catalina by placing the 2021.10330 build into a folder /Applications/Test but found as you did that the Mouse In CHOP was still functioning correctly. Maybe it’s an issue related to High Sierra?

Thanks for the tip on renaming the app! I hadn’t thought to do that before, I’ll definitely use that method from now on.