RESOLVED: BindCHOP / sliderHorz widget: constant cooking when bound value == 0 or 1

Here’s an odd one, demonstrated in the attached scene. Steps to reproduce:

  • Open attached toe file and see the chain of ConstantCHOP → BindCHOP → sliderHorz
  • Export chan1 from the BindCHOP to the Value0 par on the sliderHorz
  • Set the value to 0 or 1, either by updating on the widget parameters page or by updating the value from the ConstantCHOP; notice both the Bind and the widget are now constantly cooking
  • Change the value to anything between 0 and 1; notice the constant cooking has stopped

Tested in Windows Build 2021.11180 and Mac 2020.44250

Not sure if this is caused by the BindCHOP or by the sliderHorz widget – on the one hand, the issue does not appear when export-binding to a ConstantCHOP, but I also see no constant cooking when the widget Value0 is set to 0 or 1 without binding.

I believe this may be related to a big performance hit I’m seeing when binding widget values to a BindCHOP connected to MIDI signal – whenever I twist a knob on my controller, I’m dropping ~20 frames (this apparently doesn’t happen if the widget isn’t rendered on screen). Any red flags in that setup which I may be overlooking?

sliderBind01.toe (18.6 KB)

Hey @benjaminben, thanks for the report.

The issue is related to the field in the Widget. If you disable the field you’ll notice that the issue you describe disappears.

There is some work currently being done to improve it all :slight_smile:

In the meantime, I hope this solution helps!

Thanks,
Michel

Thank you! I turned off the field and indeed constant cooking has stopped and my framerate is back to 60 :slight_smile:

It would of course be nice to have to have the field available for precisely entering values, but this will get me where I need to be for now. Looking forward to further updates on widgets, thanks again for your help!

1 Like

There is a workaround that will let you use the field COMP. If you go to

/project1/sliderHorz/numericValue0/field

and turn OFF the parameter Enable Field Format Numbers the constant cooking will stop. The constant cooking is due to a formatting conflict between 0 and 0.0. We are working on a better solution.

We will have changed this in Widgets settings for the next Official release, so if you ‘update’ your widgets the parameter will be turned off to stop this extra cooking.