RESOLVED:Freezing moving to another app unexpected results

When going in perform mode with the settings in the attached network and clicking in or switching to another application,TD freezes, sometimes for a considerable time, and the changes done in the ui go back to a previous state. Clicking back on the perform Windows brings settings back to where they should be after a while. This occurs when passing dimensions for full screen manually or setting the size mode to “fill”. The UI behaviour is not easy to reproduce but it has happened a couple times in different machines.

This doesn’t happen if not in full screen, or if the Ignore Taskbar is set to off.

I’m doing a project where I have to switch betwen programs and this behaviour is quite disturbing. Is there something that I am missing or that can be done to remedy this while still going into full mode?

TD Build: 099 25850

Tried with a:

  • Windows 10 GTX 770
  • Windows 10 GTX1070


Update: I noticed now that this also does not happen if there’s a viewer of some node opened, while in fullscreen
TestProject.toe (5.37 KB)

Hi Qvoloid,
I could not replicate this behavior on my system (a Quadro mind you). But just to make sure I have the settings correct, I need to change it to “Fill”? The fileyou attached opens as 1820x720 in the middle of screen.

What other ‘application’ are you switching to when you are seeing this? Do I need another graphically intense application or do you see it with things like Chrome / Outlook / etc?

My hunch is that Windows goes into a Full-screen mode when you enter Perform in fullscreen and perhaps the graphic drivers is switching out of this mode when you click into the other application. On some optimius laptops this fullscreen mode can cause other issues, and a often used trick is to create your perform window 1 pixel short of fullscreen to stay out of this mode. ie. 1920x1079 resolution instead of 1920x1080. I wonder if you try this will the pauses-hangs go away?

Hi Ben,

Thanks for your response! Yes, it happens when you set it to fill the screen or when you explicitly pass the size in pixels of your full screen. In my case that was 1920x1080 (I must have mistyped those sizes in the file)

The other applications to where Im switching to can be anything, really. Chrome or a text editor, same thing.

This sounds like it actually. I have tried and I see indeed that this little trick solves the issue. So nothing from TD side but rather a Windows thing it seems!

Thanks for your help!