RESOLVED: Hang up when adding operator

Hi,
Touchdesigner hangs up frequently when I add an operator.
This problem happened frequently when I double-clicked and showing operator dialog.

I recorded this problem on Youtube. ( https://www.youtube.com/watch?v=roVYu1_BPK8&feature=youtu.be )

This problem happens when I opened initial toe file (like NewProject1.toe).

Does anyone know the solution?

I run Touchdesigner at:
Touchdesigner 2020.27390
Windows 10 Pro (I updated in a few days)
CPU: Intel Core i7-10700K
RAM: 64GB
GPU: NVIDIA GeForce RTX 2070 Super

I’m not sure what the message box says, but do you get a chance to save off a dump file? If TouchDesigner is freezing (becoming non-responsive) rather than crashing, you can also create a dump file from the Task Manager by right-clicking on TouchDesigner in the application list.

If you can post the dump file or send it to support@derivative.ca then we might be able to tell more about the problem.

Thanks for replying.
Here is the dump file, I created when Touchdesigner is freezing.
http://hi-farm.net/touchdesigner/TouchDesigner.DMP
(This is my server)

Please check the file.

Thanks for your support.

This problem happens when opening subwindow.(OP create dialog, kantanmapper subwindow by clicking “Open Kantan Window”, and so on)

Thanks for posting the dump file. It looks like it’s getting stuck inside the driver command that is supposed to copy the window onto the screen. If you haven’t done so already, its worth checking that your nvidia drivers are up to date, and we’ll take a further look into it from this end and let you know what we find.

After a little more digging, it looks like there might be an application on your system (NahimicOSD.dll) that might be interfering with the windows draw functions. A quick search online indicates that other users have had problems with Nahimic Audio interfering with games and other applications. I’d suggest checking if there is an update for that audio system or trying to disable/uninstall it and seeing if that helps.

Thanks.
The problem is not solved after updating graphics driver to latest version(457.30), and dell-recommended-version(456.87, I’m using Alienware).

I’m waiting for your result.

Thanks

It sounds like it is most likely the Nahimic sound driver. You might find these posts helpful on how to disable or uninstall the drivers so that they don’t interfere:

There are quite a few more references if you search the forums for “Nahimic” Hope that helps. Let us know if you’re still having problems.

Thanks.
I’ll check them.

Now I found walkaround, it is ok when touchdesigner opened subwindow in “Main Monitor”.
So I change monitor location in windows settings.

Thanks. It works fine after I uninstalled and stopped Nahimic process and services!

1 Like