RESOLVED: Hold CHOP doesn't cook in perform mode / unless viewing operator (Windows v2021.12380)

Hello, please see the attached toe and the following reproduction steps:

  1. Open the attached toe and navigate into the container at /tapTempo
  2. Right click on the op named buttonMomentary and select “View…” to open floating panel
  3. Click on the button and confirm that the project BPM updates
  4. Now zoom out of /tapTempo to the root network
  5. Click on the floating button and confirm that BPM does not update
  6. Now zoom back into /tapTempo, right click on the op hold1 and select “View…”
  7. Zoom back out to root network and click the floating buttonMomentary to confirm the project tempo does update while the floating hold1 viewer is open

*The issue is reproducible if instead of using floating panels you toggle in/out of perform mode from inside /tapTempo

I’ve tried this sequence of steps with every other operator in the network, the issue appears to be with the hold1 chop not updating (updates are also triggered by viewing the math1 chop directly connected after the hold). Am I missing something / if not is there a workaround??


tap-tempo.toe (24.8 KB)

Thanks for the report.

Hi Ben, it appears this bug was due to an issue with the expression on the record parameter of my recordCHOP. Sorry for the premature report, I’m marking this as resolved!

1 Like