RESOLVED: Moviefileout TOP bug in 2022.32120 : Error opening output file

After updating to the latest version of TouchDesigner, I am having this bug in one of my components where I use an expression to set the filename for recorded movies.

I get the following error when the record parameter is turned on: Error opening output file
It happens also if I don’t include the project folder and the expression just returns the file name.
Also when I copy the result of the expression and paste it as a constant.
But if I then use the file select button and hit [Save], it starts recording and the error is gone!

So I guess there is some ‘touching’ of the filename going on that is set when hitting save but not when changing the filename directly on the parameter?

moviefileout_problem.toe (7.6 KB)

including toe file:

Is that a network drive or a NAS by chance? This works for me offhand, so I’m wondering what is it about that directory that is an issue. If you move this to your C: drive, does it work?

oops deleted my post instead of updating.

The project is saved in my documents folder on a local drive. I tried saving to my C:/ drive directly and got this error:
Seemed very related, so I tried running TouchDesigner as admin and then it worked without errors in any folder. I tracked it down to Avast Antivirus (which somehow decided my updated touchdesigner should not try to save files unless in the right folders and correctly announced by using a file save dialog - no idea how it can do this…)

edit: Further tracked it down to the avast ransomware shield which is for now disabled.

Right, the root of C: is protected by the OS. It would need to be a subdir you create that you have write access to. Thanks for posting what the solution was!