RESOLVED: Right-click on MacOS X

Hello,

I’m a new user of TouchDesigner and for the life of me I can’t get right-click to work on the objects to bring up the parameters panel.

I’ve tried alt-click, alt-shift click, control click, command click

I’ve tried the key commands (some of which work, most don’t)

I even tried a Mac app called MagicPrefs to try and map a triple-finger click to right click (which worked but messed every other interaction, so it would be something I’d just have to turn on when using TouchDesigner).

What am I missing?

Thanks

Tom

Does right-click bring up any pop up menu in the network or on a node. It shouldn’t bring up parameters btw.

Have you tried a mouse to rule out trackpad issue? We have not heard of the issue before.
On a Mac the default for right-click is two-finger-click on a trackpad.

I can’t get any alt/right/middle clicks to do anything useful at all.

I don’t have a mouse.

(Sorry for he delay, still struggling)

I have managed to get there after MUCH messing about… and now double-tap command-option works (see attached) using BetterTouchTool
Screen Shot 2018-05-16 at 21.04.06.png

Glad you were able to find a solution. Still wonder what’s going on with your laptop as default macOS settings use 2-finger click/tap as right-mouse-input.

What version of macOS are you using? Were your trackpad settings all default before?

With the 3D part of TouchDesigner and many interactions in the network editor, it is much easier to use a mouse as all 3 buttons are used (left, middle, right).

I had the same reaction as the original poster - could you enable the menu to show up for command + click/tap by default? That would adhere consistently with MacOS. FWIW, it would have never occurred to me to two-finger-click on the trackpad as a way to get to the menu if it weren’t for this forum. Thanks!

1 Like