RESOLVED: TD Hangs on Python Execution

Hello, I am a relatively inexperienced TD user, so I’m not 100% sure if this is a bug, but hopefully this can point me in the right direction.

I had a project hat worked fine a year ago, I do not remember which release I was on, but it was presumably some 2021 release. I’ve since updated to 2022.29850 on Windows11, and now when I execute my main python script TD hangs indefinitely.

A few setup notes:

  • I was using alphamoonbases’ td pip v12, but have also updated that to v15.
  • With the 2022 update to py3.9.5, and a year passing, I’m sure my packages have also updated
  • Otherwise, the python script has not changed at all in the last year, so it worked fine before.

I created a DMP file, and it seems to point to something with python failing, but I’ve never looked at a DMP file before so I’m not sure how to dig deeper into it.

BREAKPOINT_80000003_python39.dll!Unknown

Question for the team: What additional information can I post here that is helpful?

best send an email with the projectfile and the DMP file to support@derivative.ca

Core functionality of TD-PIP did not realy change, I just pull the latest version of PIP directly from their server instead of shipping it in the tox, so I assume this should have no effect.

2 Likes

Thank you, I’ll send that in now.

Hey @cdabezies

Received your files and logged, thanks.

Best,
Michel

This definitely seems like a 3rd party issue in which control is not given back to the main TouchDesigner application. If TD were hanging, it would stop somewhere besides the python39.dll as you’ve shown. Are you able to try this with earlier versions of the python package?

Thanks @rob. This one is resolved. Posting in case other users have a similar question.

Yes, you’re right, the issue was in a dependency for one of my packages. My system presented an edge case that resulted in a deadlock. I fixed it in my local lib and submitted a PR to the project.

@alphamoonbase nothing wrong with your TD PIP, thanks again for making that for the community!

2 Likes