RESOLVED: TDAbleton devices still not showing

I’ve been working with TDAbleton a bit based on this video:

TDAbleton - TouchDesigner and Ableton Live - Ivan DelSol

I’m on TD version: 099 2020.26630
Mac High Sierra

Following the instructions, I have placed the TD scripts where they need to go. In this case:

MIDI Remote:
/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts

Preferences:
/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7
(MYUSER hidden for security here)

So far, I can only get TDAbleton to work if I drag the Master and Level devices into Ableton manually. I’ve tried three examples from scratch, following all of the instruction on the wiki.

Touchdesigner is showing up in Ableton fine as a MIDI source. That is not an issue. I have a basic 8-track reactive project between Ableton and TD working. It’s just that I had to do it manually.

This wouldn’t be so bad, but I noticed things get more complicated if I want to use the TDA Audio Analyzer Rack (see attached). In that case, I get some indication that the component is connected, but I see no data coming across.

Since the abletonLevel nodes only show level (not frequency), I’d like to use the TD Audio Analyzer to capture those parameters. That’s easy of course, but not given the current issue I’m having with basic setup. I see a few others have experienced this, but the solutions usually center around not having any of the files where they need to be. But I don’t see that as being the case here.

Do you have the TouchDesigner folder in your Live User folders? That is probably the problem with not getting devices properly. 40k experimental has a much easier installer if you don’t mind moving from the official release.

Regarding abletonLevel, you should try it in Rack mode. That’s how you get different frequencies, using Ableton filters. TD Audio Analyzer won’t work because you can’t get the actual audio mode.

Thanks for the suggestion Ivan. I have the following folders set up:

MIDI Remote:
/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts

Preferences:
/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7

Ableton User Library:
/Users/MYUSER/Music/Ableton/User Library/TouchDesigner

I’m ready to start over with this. Do you have a link for the 40k installer?

I’m starting from a fresh TD file and fresh Ableton project, and this is what I get:


I did some more digging… first I confirmed where the TDAbleton assets are placed:

/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts
/Users/MYUSER/Music/Ableton/User Library
/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7/User Remote Scripts/

Then I checked the error log here:

/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7/Log.txt

I see one error:

File “/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts/TouchDesigner/TDA.py”, line 444, in addDevice
self.debug(‘deviceDict:’, deviceDict)
NameError: global name ‘deviceDict’ is not defined

Still not sure what that means exactly, but guess I am getting close.

And here’s the error when I try to pulse something over to the Live project from TD:

In the older versions you need to drag the TouchDesigner folder (same one you put in MIDI Remote Scripts) into your Live PLACES. Sorry, it’s not the “User Library” you need to put it in… it actually belongs next to the User Library.

For new versions, you can get experimental versions here on the site. Link is at the bottom of the download page… https://derivative.ca/download/experimental

Thanks for the additional suggestion, but that didn’t work either. Even with the TouchDesigner folder in the Ableton Places folder, the action of pulsing devices over to Ableton doesn’t work.

For kicks I tried adding an additional copy here:

/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7/

And that is in addition to the locations I’ve already tried:

/Users/MYUSER/Library/Preferences/Ableton/Live 9.7.7/User Remote Scripts/
/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts
/Users/MYUSER/Music/Ableton/User Library
(as well as “Places”)

I would think by now one of these permutations would have worked! :slight_smile:

You need to put the TouchDesigner remote script folder that you added into Ableton in there. It’s in the location that you went to in the initial installation process.

I really do appreciate the help Ivan, but that last instruction wasn’t 100% clear.

You said… " You need to put the TouchDesigner remote script folder that you added into Ableton in there."

In where??

What I thought you meant was to move the script folders into Places as well. So I have tried dragging both User Remote Scripts and MIDI Remote Scripts folders to Places…

After making this change, I clicked install from within TDAbleton (as I’ve been doing).

Still doesn’t work. Unable to automatically pulse devices over to Ableton. Have to add them manually. I’ve been getting to the prompt to assign TDSong on the master channel, but when I click Create, the device simply is’t added.

Still getting this error:

File “/Applications/Ableton Live 9 Suite.app/Contents/App-Resources/MIDI Remote Scripts/TouchDesigner/TDA.py”, line 444, in addDevice
self.debug(‘deviceDict:’, deviceDict)
NameError: global name ‘deviceDict’ is not defined

You’re so close! The TouchDesigner folder from inside that MIDI Remote Scripts folder is what you need in your PLACES. It should have some TDA devices inside it.

Once you have that in there, restarting your set should work without error. If it doesn’t, post your Ableton log file here. Instructions for getting that are on the wiki.

OK, we’re getting there…

The good news: Moving TouchDesigner folder to Places as you describe above to me to a point where devices can be pulsed over. So that is a big improvement (though it was not at all clear in the original instructions or video - some screen shots would have helped with this).

The bad news: Either because of inherent issues with the file structure or confusion from all of the crazy work above, there’s still some “media file missing” errors that need to be cleaned up. See below.

I should be able to work through that, but it is not clear to me why it is happening right now.

Once I get this cleaned up, I can get back to the original task - frequency filtering between Ableton and TD using these modules.

Yes the old installation process was a little confusing. It is much easier in 40k versions. Glad you got there.

Your device missing messages are almost certainly from your experiments. Find the corresponding devices in your PLACES/TouchDesigner folder and drag them onto the corresponding device in that Missing Media Files area.

Then we can get on to frequency analysis :slight_smile:

Thanks Ivan. Things progressed much more after doing some cleanup. I’ve already worked through the frequency stuff. Now trying to apply this to some creative uses (rather than just technical setup).

Happy holidays!

1 Like