RESOLVED: TDAbleton TDA Level bug

I have pretty straightforward project using Ableton and TD together. In Ableton I have a few TDA Level devices on the end of some tracks, all being referenced in TD by a specific name: “level”. See screenshot for settings…

Everything works fine with my initial use. But every time I save both projects, then come back later and re-open them the TDLevels appear to be operating in Ableton but no data is received by TD. I’ve tried changing the settings in TD to reselect them, and deleting and recreating the tdaLevel TD operators… but nothing works from the TD side. The only way I can get it to work again is by deleting the M4L devices on each track and recreating them. On the previous version of TD & TDAbleton this only happened occasionally, but now it’s happening every time consistently.

TD Version: Mac M1 - 64-bit 2022.32660
OS: MacOS Ventura 13.3.1 (22E261)
Ableton Version: 11.2.11
TDAbleton Version: 2.0.2

Please help. Thanks!

Hey @hekuli

Apologies about the delay.

Did you figure that out ? I’ve logged it nonetheless for a dev to come back to you.


Ack! Sorry I must have missed this when it was posted.

If this is still happening, please send me your .toe file and .als file and I will see if I can replicate/fix your problem.

If it’s not still happening, I’d be curious to know what fixed it, if you know.


I just tried creating a very simple project to reproduce the bug and couldn’t. I have since upgraded my computer to all the latest stable versions (MacOS, TD, TDA). So maybe one/all of those just fixed it.

I haven’t been using my big TDAbleton project lately so I haven’t come across it lately. I’ll be getting deep into that soon and will post back here if I see it again.

Great. Always happy to look at the real world use cases/bugs

Hi @Ivan I’d like to please reopen this bug.

Now that I’m back into developing my TDA project more, I’ve been encountering this quite a lot. It’s really hard to provide consistent steps to reproduce b/c it happens so randomly. I’m seeing similar issues with other TDA components (abletonSong and abletonClipSlot) for example. They all exhibit the same behavior: No network errors or system crashes, the TDA comps say they are connected, but some of the channels disappear or get stuck at a particular value, or are always zero. Sometimes toggling the cook flag on the comp fixes it, but often times it does not. Usually if I restart both TD and Ableton things start working again.

Since I don’t see any errors or logs, how can I get you more info for troubleshooting this?

P.S.: I am still on MacOS Ventura. I’m waiting to upgrade to Sonoma until the other crashing issues I read about in the forum are resolved.

For example I just spent the last hour trying to figure out why the abletonSong channels: [bars, beats, sub-divisions, ticks] suddenly stopped working (the first time this particular incarnation of the issue has arisen).

I tracked it down to the /tdAbleton/oscin_time CHOP. The values there were completely frozen. Toggled the bypass flag, deleted & recreated tdAbleton Comp, changed the OSC ports, restarted Ableton, restarted Touchdesigner… nothing worked.

Finally I deleted and recreated the TD_Master M4L device on my Ableton master track. That somehow did the trick.

This is so buggy and happening to me on an hourly basis, it’s nearly unusable. I’m afraid to use it in a performance setting. It’s completely inconsistent so I never know which devices or nodes to delete recreate or what program to restart.

Can you do a collect-all and save of your ableton set, then email that and your .toe file to If you can’t provide steps, I can try running things and seeing if I can get something stuck. I would definitely like to figure out what’s going wrong for you!

It sounds like the problem is Ableton not successfully broadcasting information. Very difficult to know without a test case?