RESOLVED: Vulkan Error while running (on different machines)

Hi, I have 6 pc that operate 18 projectors (3840x2160)…
Unfortunately is not 3 projectors per PC… different configuration between 2 and 5 projectors.
Each PC has also a FHD control monitor.
The PCs are Ryzen 9 5900x with Radeon 6900xt 32gb ram (except for the 4 and 5 projectors that have Radeon 6950xt), all of them run with Win10.

To have enough outputs I have some MST HUBS on some machines.
I aligned, masked and blended all the projectors…
So now…
For each machine I have a different video… it’s remapped (UV openEXR) and masked… then they are all put into a single window and projected.
Everything’s worked fine… except that every once in a while (random) some of the machines throw a “Vulkan error”… (… stuck in a loop… etc…).

Already tried different “flavors” of drivers… at the moment (the best solution) is with AMD Adrenaline PRO drivers (22Q2)… with TD release 2022.29850.

Nonetheless the only certainty is that the error WILL happen… even if this configuration is slightly more stable (I never reached 30 mins without errors at the moment).

Since the opening is next week and this should work at least 8 hours a day flawlessly, I would greatly appreciate some advice…
Thank you

P.S. No… I am not using any GLSL programming, just the remapping and compositing for masking…


Thanks for the report.

Sorry you are encountering issues.

I see that 22Q2 is not the latest AMD driver.

Did you try the recently released 22.Q4 ? (PRO)
Did you try the recently released 22.11.1 ?


When the project crashes, do you get any crash dump ?


Yep… already tried the driver (PRO and nonPRO)…
and I tryed TD from version 2021.1690… (probably not ALL the combinations…)

Where should I find the crash dump?

And you had the issue in 2021.x as well ?

The crash dump if any would be next to your .toe file. A .dmp file.

If nothing solves it maybe you want to share your project by sending it to support at so that we attempt to reproduce on similar hardware.


Yep… I tried that this morning…
the problem is that it comes out on different machines (but usually the ones with more outputs…)
I can share the project, of course.

I will send it tomorrow in the morning.
Thank you

As an update, this issue seems to have stemmed from an issue with the system RAM.