RFE: switch TOP cooking behavior

If blend between inputs is on, it would be great if the TOP would internally turn the blending off if the index parameter is at 0 or 1. The reason beeing that not both inputs need to be cooked in that case.

3 Likes

Wow just came here to post this … 10 years later.

Nearly any time I instantiate a Switch TOP that’s going to blend, I go into Blend Between Inputs and set the value to ‘me.par.index != 0 and me.par.index != 1’. Would be nice if this were the default behavior.

3 Likes

Yeah ditto here, I always thought this was expected behavior for some reason related to having a TOP network cooking and ready were the index parameter to change suddenly, but now that I look closer that doesn’t make sense cause it only affects the next TOP in the switch TOP list, not also the previous.

I like your solution and will also add that me.par.index % 1 != 0 works for any number of inputs, though is not optimizable python : - (

2 Likes

Great hack! Yeah this could be default. Also see my RFE from …2017 :wink: