Rouge Platform

I can reproduce this and have submitted it as a bug. Thanks for pointing it out.

it would be great to have a 88 version so we can play with including the generative freebies recently released based ont he generative code form the book…

I’ve made a small edit which now keeps the 088 version from closing when you “Enable Output” or change the resolution.

The fix was just to comment out the closing and opening of the Perform Window with each change in the script /perform/ConfigWindow. TouchDesigner 088 handles these size changes without the need to close and reopen the window, and for some reason the quick close/open was causing the window to disappear.

Enjoy!
Rouge088.toe (284 KB)

yes im having the same trouble saving out the component files… it WAS working. now isnt… not sure why… doing it manually seems to be ok…

secondly im a bit of a new but i want to do a composite node int he component and pass that up but it seems that the rouge main section only pics up geo nodes not the display node? how can i get around this please?

Can anyone explain why my Composition looks fine in it’s own window, but in the render TOP it appears like there is no light? I don’t see any lights in any of the examples.

rouge_phong.jpg

Here is the code for my Composition:
http://www.derivative.ca/Forum/download/file.php?id=2647

tgresier,
The examples have material-based lighting. Use a constant material, or set your Phong material to emit. I like mat-based lighting because it is very lightweight. I updated your tox.

drxian,
I think I will make it easier to do 2D generative stuff as Compositions, but for now you can put your 2D image on a card. I’ve attached an example.
2D-example.tox (1.76 KB)
SphereDance-lit.tox (3.83 KB)

Rouge088 with a bug fix: adding new bins works.
Rouge088.toe (287 KB)

Hi there,

(On my setup in TD 088 the droplists for compositions and show output don’t work. If you navigate to the base level within the comp with the droplist it will work but once you go up a level there is no clickthrough for the click select. Example, you can drop the list but the selects don’t work when in perform mode.)

EDIT: I see this is a problem with recent TD Builds.

The latest experimental should no longer have this issue.

Grab build 12110 here:
Experimental Builds

Hi Ben,

I did a clean install of the latest TD experimental build, I still have this problem. I’ve linked a youtube video of the problem. Maybe you can see a crucial setting in the vid, this is the latest 088 Rouge build Mary posted without alteration.
The 077 Rouge version is working fine.

youtu.be/IO667StxdGU

EDIT: I’ve gone through and replaced all the droplist elements, the replacements seems to work fine.

this question is regarding your most recent sphere dance comp.

When I use the Mic option, the spheres appear very small, almost non reactive despite playing with the sliders on the left. When I switch the input to “file”, the spheres behave as normal. I cannot, however, figure out how to change their output color.

I’ve gone into the composition - it says there are two errors, one in the constant1 chop (undefined b1, b2, b3 variables) and in the sel_control chop (invalid source: “…/control”).

Any ideas?

Thanks.

Grab the latest version from my github:

https://github.com/tgreiser/touchdesginer-ir8-comps

Here is an example of how it should work. Note, I built this for my own audio processing system and it doesn’t really react the same way using the Rogue system, but I just wanted to get a feel for how to build a Rogue Composition. If some spheres are small and others are big, then “it’s working”.


http://i.imgur.com/dWdp2EQ.jpg?1

Pick “Mic”
Smooth - I like it turned down
Audio - up
A - up
B- color

Debugging audio reactivity - You should see the high/mid/low buttons flashing, if not, you might need to check your system audio setup.

It seems like the latest 12420 build of 088 64-bit has an issue with dropdown menus… I can see the names of the Comps and Filters when i click on a menu, but i can’t choose anything.

When i switch to Edit Mode the menus work fine, but when i go in Perform Mode again - i can’t select any names from the dropdown list…

Hi! I am working on a new release, I’ll put it up by the end of the week.

Thanks for reply and great to read it! Looking forward to play more with this such a great tool (meanwhile Build 10780 works fine with Rouge).

By the way in my opinion Rouge is very useful and amazing made, and the more i explore it the more i learn for Touch. Glad to have it!

The new 088 release is up here:
http://www.maryfranck.net/rouge/

It has some new features, including presets for compositions, LFOs, more MIDI control templates, plus new filters and compositions.

Hmmmmm… somewhere down the line I’ve seem to come across a bug of some sort.

I first noticed a few days ago that the top half of my movie bins was inaccessable - meaning I can not get the scroll bar higher than half way. This is driving me nuts. I created a new bin - same thing.

I tried older versions of the project - same thing. I downloaded a new copy of rouge and tried it - same thing. Can’t get the scroll bar to go up more than half way. What’s going on here?

It hasn’t always done this, but yet it seems to be related to my systems since even a new fresh rouge project produced the same results.

help please? :slight_smile:

Still having the same issues… I guess nobody has seen or heard of this before… idk…

See Below

I think I found a bug and I’m not sure how to fix it.

Summary: I need to control the alpha of the realtime component with my midi slider. Can someone tell me what name my channel needs to be to accomplish this?

alpha (controls the main alpha), alpha1 (controls the moviebin first video alpha, not the realtime alpha like it should), alpha2 (follows suit; controls the second video of the moviebin component), alpha3 (same thing; movidebin video 3), alpha4 (did nothing)…

In the controller mapping, I noticed that when I set my 4 sliders to rename to channels ‘alpha1, alpha2, alph3, and alpha4’ alpha1 always controls alpha2 of the Movie Bin.

And then alpha2 controls alph3 of the Movie Bin, and so on.

In my attempt to understand why, I noticed that the MovieBin sliders are first named alpha1, and then renamed to alpha2.

For example, in /Video/VJ/MovieBin/layers/layer1/>> add3 and limit1 channels are first named alpha1, and then renamed to alpha2. But yet, the midi channel I have renamed to ‘alpha1’ is controlling this instance…

So I go into /Video/VJ/Realtime/>> and see that it’s add3 and limit1 channels are called ‘alpha0’ before being renamed to ‘alpha1’.

To follow suit based on the response I recieved earlier, I tried renaming my midi channel to ‘alpha0’ but it didn’t seem to do anything.

So… right now I’m not sure what’s going on. I need to control the alpha of the realtime component with my midi slider. Can someone tell me what name my channel needs to be to accomplish this?

alpha (controls the main alpha), alpha1 (controls the moviebin first video alpha, not the realtime alpha like it should), alpha2 (follows suit; controls the second video of the moviebin component), alpha3 (same thing; movidebin video 3), alpha4 (did nothing)…