Slamtec RPLidar support - 2023-05-19 10:58

Slamtec RPLidar support

Link to main site

amazing work !! was such of a pain before . will it work with the S3 ?

This is great!! Any chance for an S3 Support?

Hi I have a question. When I use it, it initially works and then suddenly stops, can I know why?

The USB version works for about 30 minutes- it seems to be worse with a longer run of cable, though it could have been the model of USB over Ethernet adapter I had. Toggling it on-off about every 10 minutes solved the issue.

Great work! Does it support the new RPLidar C1?

Yes, SDK updates to the latest one, someone already tried it with S3, but I haven’t had the chance by myself yet.
Support of C1 baud rate added, but didn’t have a chance to test yet. There are quite a few complain and issues in the official repo for C1, so for now maybe wouldn’t suggest using it, need to wait SDK fix by Slamtec.

In general long USB cables are a bad solution for long-term projects, only use optics. I prefer to use network versions of the Slamtec lidars. There also needs to be sure it is not activated by default when the TD starts, it can cause problems. I disabled the plugin on save and activated it a few seconds after the program started.

@Vasily I have tried to configure RPLidar A3 with Touch designer over TCP Network connection. However, i am unable to receive data inside Touchdesigner. I have gone through the process shared by you on GitHub repo. Is there any way to configure the lidar over TCP network in Touchdesigner then please let me know.

For your information: I have checked inside Robo Studio whether lidar data connection over TCP network is working or not. However, i can able to receive data in Robostudio over Network. So i thinking Network connection may not be issue.

Hello. You need to check what port you trying to connect to. I suppose you using this kind of adapter with RPLidar A3

image

Check the right port and the address, be sure your network set up right too.
image

You can download this tool to check the connection port and change the address for the lidar https://www.pusr.com/support/download/Setup-Software-USR-M0-V2-2-6-1-exe.html

image


Screenshot 2024-06-21 120142

Thanks for the help. I am sharing screenshots of USR Software regarding TCP/IP connection of my device as it is showing that data is sending by device. Also I have set the same config inside Touchdesigner. However, still i can not able to receive the data in TD. Also, the lidar is not moving physically once i turn on the Cplusplus CHOP inside TD.

But as i mentioned earlier, the lidar connection is working inside Robo Studio.

Is there anything i am missing to setup for receiving the data in TD.

@Vasily this is also happening to me, I got the Ethernet Module you’re showing in the photo for a S2L and in Robostudio it recognized and I can see scanning, but in the Cplusplus with the same network config is not working, when I connect the S2L via USB to the cplusplus is working ok in touchdesigner

This is interesting. I used it with S2L and S2E multiple times and didn’t have a problem. I will take a look at it coming days as on a business trip now. You can attach the infoDAT to the cpp chop to see if it shows any information or error.
Also can try to to deactivate lidar, unload the plugin, load it, reset, and connect again.
Can try this version also.

@Vasily now im trying with a S2E and its not working with V4, I try with V3 version from your link and its working good!! I attach photos from V4 and V3 with the infoDAT

Ok, Thank you. I would check more V4 versions as it uses the new SDK, looks like there few more changes inside of it. For now, you can use the V3 version.