Slightly different 2nd monitor crash issue

Specs:
TD Build 27390
Windows 10 Pro OS build 19042.630
GPU: 2080Ti (driver version 457.30)
CPU: i9-9900K
MOBO: Asus ROG Strix Z-390E

The issue I have is similar to one described in some other threads, but my system specs are a bit different and none of the fixes mentioned have worked for me (though I haven’t wiped my whole system as some people mentioned).

The problem occurs any time a new window is opened on a monitor that is not set to the main display. This is true even if it is a textport window. This issue follows whichever display is set as the main display in Windows. I’ve tried this in configurations with 2 and 3 monitors and if you open any TD window on a display that is not set as the main display, TD hangs without any kind of dmp file or crash save generated. Any windows opened on the main display can still be dragged onto additional displays without a problem.

This issue seems like it also may have started at about the time an update from adobe creative cloud ran…

There was one piece of bloatware, “Intel Graphics Command Center”, which I uninstalled. I also ran Windows update and did a clean install on my graphics driver, to no avail. Also for what it’s worth, all of my displays are plugged directly into my GPU, none of the MOBO HDMI or Displayport are used at all.

Any tips would be appreciated!

After continuing to work, somehow clearing out bloatware and making sure everything was updated fixed this. I didn’t change or reboot anything, it just randomly started working fine again. Leaving it here in case it’s still useful info, since I did kill a few hours on this.

I have the same issue I would like to add that this appears to be tied to using HDMI to a second monitor.
I have been using kantan. If I set output to monitor 0 I do not have a problem, when set to monitor 1 I have a hard crash forcing me to close TouchDesigner. I have a second system a Desk Top that works with no issues, and does not HDMI to the second monitor.
The problem system is a laptop Dell G7 17 7790, i7 CPU, 16 gig memory and a NVIDIA 2060 GPU. Running Windows 10.
I have tried this with 4 projectors and multiple monitors with the same results, as the laptop main output is HDMI.

@DeanDay This is almost always some preinstalled software from the factory on laptops, we’ve seen it countless times. You didn’t mention the graphic drivers you are running, it is also wise to update those but I’m willing to bet on some bloatware.
The reason it is HDMI versus other outputs is that these laptops are all setup with Optimus and the HDMI is often directly connected to the Nvidia GPU whereas the internal monitor is wired to the Intel integrated GPU (even work done by the Nvidia GPU must travel through the Intel GPU to reach your laptop’s screen).

You can also play with the Nvidia Control Panel settings to force Nvidia GPU usage, but this often only helps with vsync fighting, not the crashing you are reporting.

Hi! I have the same laptop and the same problem. Any project crashes when I display it on a second monitor. Did you manage to solve this problem somehow? (I tried uninstalling Alienware but it didn’t work for me).

Thank you for a courteous reply! You are correct, and I am still recovering from a clean install of windows 10. My development system is both well used and well loved.
Sorry for a delayed reply. COVID took out my project, I had to cope with a remote audience. So after the clean install of Windows 10 I have been rebuilding my development system and checking for TouchDesigner for function, so far it still works. If/when it breaks I will relay what I have found.

@ArsosArsos Have you updated your drivers? You have the Asus? I think there is other bloatware on those, perhaps some GPU acceleration/overclocking software? I would disable any of that stuff if not uninstall it.

Hi Ben, thanks for your feedback. No, I have a laptop:
My DELL G7 17 7790 laptop:
processor: Intel Core i7 9750H (2600 MHz)
video card: NVIDIA GeForce RTX 2070 Max-Q (8 GB)
Windows 10 Home
All drivers are on the latest versions.
I read above that it is possible to uninstall Alienware, but it didn’t help me.
Apparently you need to experimentally remove standard applications in order to understand which of them can be “bad”