SOLVED: [2021.38090 - Win11] Vulkan Initialization failed

Have you tried to change your nVidia driver to the last studio version (472.84) and not the last gaming version?

Thanks for your suggestion @jacqueshoepffner , unfortunately it doesn’t solve the issue. I got the exact same behaviour with the latest Nvidia Studio Driver.

I tried starting Touchdesigner from WinDbg, here is the result:
vulkan_initialization_failed_debug_dump.dmp (23.3 KB)
Hope this helps

Couple things off the top of my head:

1 - are you sure Touch isn’t somehow trying to launch using the integrated graphics? Can you disable it to make sure?

2 - how are you reinstalling drivers? Sometimes a clean install can solve issues. By clean install, I mean uninstalling first, and then installing, or even going so far as to use a driver cleaner tool. On some No Man’s Sky forum posts with a similar error, people mention solving the issue with clean installs.

3 - consider this nvidia page: Vulkan Driver Support | NVIDIA Developer - the most recent vulkan specific driver is from 12 days ago

@michelchrome Just wanted to add to this, I have a laptop with identical specs (except that I’m running Windows 10 Pro rather than 11) and am running into the same issue.

Tried updating to the latest game ready driver as well as the studio driver with no success. Going to try @matijaerceg’s suggestions now.

For posterity: are people opening a fresh .toe or one that already has other stuff in it?

@matijaerceg This is happening regardless of whether I try to open TouchDesigner from the desktop icon or try to open a .TOE file with this particular version. The error message pops up before the “Loading…” dialog shows up on screen (as in I never actually see the “Loading…” dialog, TD closes when I click OK on the error message).

I found a solution for my specific case: My laptop is from PCSpecialist (chassis, motherboard and GPU are built by TongFang), and it came preinstalled with a software called Control Center which allows me to set keyboard light color, battery saving mode, etc.
In this software I activated an option called “Display Mode”, which forces the computer to use only the “dGPU” (I assume it means discrete GPU, so the Nvidia one), enabling this option solved the issue for me. Now Touchdesigner opens without any warning.
However, it still annoying because I must reboot my computer each time I want to toggle this “Display Mode”, it would be better if Touchdesigner could use the graphics card specified in Windows graphics settings. I will try to reinstall or update the AMD graphics driver to see if it helps.


Just for info I have a rog strix laptop with Amd integrated graphics and nvidia rtx3060.
Asus updates did not solve the problem cause they don’t install last amd graphic card driver.
I solved by installing directly last amd graphic card driver

1 Like

Sadly, sounds like bloatware issues for both of you, even if you don’t call those bloatware… :sweat_smile::sweat_smile:

@shieman Asus laptops often (if not all the time ?) come with Nahimic which is known to make a mess of everything Nahimic Service full of problems

If your problems persist even after driver update, I’d look down that path.

@michelchrome What happens if you uninstall that control center thing entirely? Does it get rid of your issues and allow you not to reboot your laptop all the time while keeping GPU choice to default/system choice. Let me know if the AMD update fixed the issue.


@jetxs after updating driver Td works now.
I even tried python 3.9 with onnxruntime gpu.

@JetXS Yeah I know this kind of laptop-specific bloatwares can lead to a lot of issues, but unfortunately in my case I can’t find another way to control some settings related to keyboard and fan control.
However, I updated the Radeon Software and it solves the issue ! That was really simple after all, but I didn’t thought the integrated graphics driver could interfere.
Thanks a lot.


Amazing, congrats!

And thanks @shieman for the tips!


Just wanted to follow up and mention that I was also able to solve this, but with a different method than above. I’m also using an ASUS ROG Strix.

I tried the above suggestions of updating the AMD and Nvidia drivers without success. Also tried removing the AMD Control Center as well, which still didn’t work. My computer wasn’t running any of the Nahimic processes, so wasn’t able to test that.

Finally came across this article Unable to launch Vulkan apps/game on notebooks with AMD Radeon iGPUs | NVIDIA on Nvidia’s site which appears to have solved it! I’m now able to open the experimental build regardless of whether I’ve got the computer set to use the Nvidia GPU or the AMD internal graphics (and am still able to switch between the two, FWIW).


Great find @jackdilaura, thanks for reporting back!

1 Like

This solved my problem too! Thank you so much!

1 Like

Thank`s a lot man, that helped) Even with the later versions

thank you, sir, solved my issue as well!

Having the same issue on newly installed Windows 10 (DELL precision M6600 with NVIDIA Quadro 4000M). I tryed several versions of drivers, but TD just refuses to run

Are you getting your drivers from or Dell? Please use