SOLVED: 3-letter icon not displaying

3-letter icon doesn’t display on any operators when I click the top-left “Viewer” button, just dark-gray solid color.

Also strangely, Text TOP can’t load Verdana and many other fonts.
I get error “Warning: Parameter(Font) Failed to open file: Verdana”
and “Warning: Failed to load font. Substituted font with Verdana.”

Running version 2021.15020 on Mac OS Big Sur 11.5.2.


Hey @invisiblesignal

Thanks for the report and apologies for the delay.

A few questions to help debug this issue, if you don’t mind:

  • Do you have multiple user accounts on that machine?
  • Is the user account you are using Standard or Administrator? You can see that by going to System Preferences → User And Groups
  • In Finder, go to System/Library and right-click on the folder Fonts → Get Infos, in the section Sharing And Permissions, what do you see? Is there read access for everyone? is there a setting specific to your current user account ?
  • Lastly, in System Preferences, go to Security and Privacy, select Files and Folders. Do you see TouchDesigner on the right side ?


Thanks, I missed your reply also for awhile so no worries.

  • Yes, my account is Admin and also there’s another Admin account created by my department’s IT staff (I’m in academia)

  • The Fonts folder is set to Read Only for everyone. No, my specific user account is not listed.

  • Yes, TouchDesigner is listed in ‘Files and Folders’ and has a single item underneath that is checked ‘Desktop Folder’

Hey @invisiblesignal

Thanks for the answer.

Yes, my account is Admin and also there’s another Admin account created by my department’s IT staff (I’m in academia)

  • Can you install a custom font yourself ?
  • Any chance that you get from IT information regarding your own admin account? Do you really have full permissions just like a regular admin account or is there something that differs ?
  • Is it a local account or network account managed by Active Dir (or equivalent network account protocols) ?

Apologies for all the questions, it’s a tricky one to debug.

Thank you for your time,

FWIW I can get around the Text TOP problem by adding the Font File to my working folder and referencing it there. Doesn’t help with the 3-letter icon problem though.

Strangely I have Fonts in four different locations on this machine, I’m guessing as a result of doing a Time Machine restore from an older machine. Verdana is located in System > Library > Fonts > Supplemental for some reason, and I can’t drag it into the main Fonts folder. Can’t change my permissions to Read/Write, even though I’m an admin user. It seems that every font that is in this System > Library > Fonts folder is working properly in TD, but not ones in this Supplemental folder.

Yes, TouchDesigner would look only at the default location, especially for the 3-letter icons.

I think we’d need help from your IT department to figure out what is going on.

Possibly a fresh install without time machine as well, if at all possible.

Thank, I posted the last one without seeing your latest response. I tried downloading some other font, put the .ttf file in Library > Fonts, and Text TOP can display it properly. However, I am unable to add anything to System > Library > Fonts because I have Read-Only permission, and am unable to change that the Read/Write. So to your question, it appears I actually don’t have full permissions. I believe it’s a networked account.

The font that TD needs for the 3-letter icons is Verdana, correct? So if I can get my IT people to give me Read/Write privileges on that System>Library>Fonts folder and put Verdana in there, perhaps that’s the solution?

ok that’s what I will do

1 Like

Oh boy, it seems that Apple really messed us up here with the way it’s handling fonts in Big Sur… See the images for how the folder looks. Big Sur automatically creates this Supplemental folder that has a whole lot of fonts inside, including Verdana. My IT person logged in as a root user and still was unable to move these fonts from Supplemental to the main folder. Doing a “Restore Standard Fonts” in FontBook also didn’t change anything.

So, the only fix I can imagine would be to make TouchDesigner look not only in System > Library > Fonts, but also all subfolders within that.

Any other ideas for something to try over here? Thanks

Hey @invisiblesignal

Just checked on the Mac Mini M1 I have here and I do have the same setup, with the Supplemental folder and Verdana being inside.

I will check with the developers but that would mean TouchDesigner is already properly checking where the fonts are by default.

Are you still on Big Sur 11.5.2?

This (I am on 11.6) and the network account are the only differences between our setups I can think of
so far.

Welp, I’m confused but now it’s working perfectly. After doing the steps outlined above I opened TD and, weirdly, all the UI text was italicized. Verdana was displaying in Text TOP now but also italicized. 3-letter icons were displayed! I checked Font Book… Verdana Regular was now turned off but Italic, Bold and Bold Italic were on. I turned Regular on, then opened TD again, and voila everything displays properly.

It’s a mess but my hunch is that the “Restore Standard Fonts” operation in Font Book actually did the fix, in case anyone else encounters this problem.

FWIW I had already upgraded to Big Sur 11.6 and that didn’t change anything.

Thanks for helping out w this.

1 Like