SOLVED: Can't open TouchDesigner2022 on 2018 Mac Mini running Mojave 10.14.6

Was super pumped to try the new TouchDesigner2022. After installing and running the app, I get this popup:

The application “TouchDesigner” can’t be opened.

then another popup comes up:

TouchDesigner 2 cannot be opened because of a problem.
Check with the developer to make sure TouchDesigner works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.

Click Report to see more detailed information and send a report to Apple.

I’m running Mojave 10.14.6 on a 2018 MacMini
Previously version worked great.

According to the system requirements on the download page, I meet the minimum:

macOS 10.12 or higher

  • Nvidia GeForce 600 Series or better
  • AMD Radeon or FirePro
  • Intel HD4000 or better
    Mac Pro / iMac / Mac Mini mid-2012 or newer
    MacBook Air mid-2012 or newer
    MacBook Pro (Retina) late-2012 or newer
    3 button mouse or 2 button mouse with scrollwheel

I just wanna play with the new toys :frowning:

Hey @superlotek

Apologies for the delay and thanks for the report + the crash log sent by email.

A fix for this issue will be available in the next build we release.


Having a similar issue. Not able to open a freshly installed Touchdesigner on my 2019 Mac with the latest software update (May 2022). It says that the programme cannot open on this Mac even though meeting all the requirements necessary.

Hey @mulqueeh

Thanks for the report.

Can you please share the complete specs of the machine, similar to what the original poster shared in his post above?


We are in the middle of updating the minimum requirements. MacOS 10.14 and lower is causing a number of issues due to out of support drivers. 10.15+ seems much better on many machines if you can update?

Either way, can you go to the Console App and under User Crash reports send us the crash from TouchDesigner?
Thanks for your patience.


Sorry for the delay in response. My Mac’s specs;
MacOS Moneterey Version 12.4
MacBook Pro (13-inch, 2020, Two Thunderbolt 3 ports)
Processor 1.4 GHz Quad-Core Intel Core i5
Memory 16 GB 2133 MHz LPDDR3
Startup disk Macintosh HD
Graphics Intel Iris Plus Graphics 645 1536 MB



Could you please give a try to the build we just released and let us know if it solved your issues?


It works! Thanks so much :slight_smile:


This is an old issue but just wanted to report the same issue “Touchdesigner can’t be opened” on my M1 2021 mbp, downloading latest build seems to have fixed it

Having similar issue, latest TouchDesigner downloaded but cannot open and says that the application is not supported on this Mac. My Mac does meet the minimum according to the download page, but no idea why it does not work.

Here are my complete specs of the machine:

  • Processor: 2,3 GHz 8-Core Intel Core i9
  • Graphics: AMD Radeon Pro 5500M 4 GB / Intel UHD Graphics 630 1536 MB
  • macOS Sonoma: version 14.2
  • MacbookPro 16-inch 2019

Hi - sorry to hear you’re seeing issues. As a first step, could you update to the latest version of macOS (14.3) and let us know if the issue persists?

@BItna could you check you’ve downloaded the Intel, and not ARM, version of TouchDesigner? You can check the version you have in the Finder if you select TouchDesigner, then File > Get Info (or right-click, Get Info) and the “Kind” entry should show “Application (Intel)”. If it shows “Application (Apple silicon)” then delete the app and download the correct version.

1 Like