SOLVED: Line MAT Issue (Red/Blue Checkerboard)

Hi all,

Getting a blue/red checkerboard on my Line MATs.
Updated to 2021.15240 (64bit Build), as well as my GeForce Drivers (2060 Super EVGA) this morning, and have been getting the error since.

image
image
image

Is this purely on my end or can someone reproduce this?
Any help would be appreciated.

Thanks,
Mike

Yea I’ve just started seeing this as well, updated my drivers a few days ago. Seeing an issue with Geometry Shaders as well ‘max_vertices must be declared for GLSL geometry shaders’, but not sure if that’s related. I’ll raise a separate issue, if one doesn’t exist already.

Also on a 2060 super, with drivers: 496.13

image

1 Like

Hey @mkhayata @thoseEyes

I can confirm I can reproduce it on my end.

Probably not caused by the GPU, but we all share the same driver version…

I’m logging this issue for a dev to look into it.

Thanks,
Michel

1 Like

Great, thank you @JetXS and @thoseEyes

Just rolled back to driver version 456.71 and Line MAT / Geo Shader now working :+1:

2 Likes

Awesome, I’ll do the same!

Confirmed that this is a regression in Geometry Shader behavior in the latest Nvidia driver. I’ve submitted a bug to them. Thanks for the report!

1 Like

The 47x.00 series of drivers should work fine as well. You don’t need to roll back all the way to 45x.00 series.

1 Like

Yep, rolled back to 472.12 yesterday and all is working fine.

Hello everyone,

Nvidia drivers version 496.76+ published on 11/16/2021 are introducing a fix for this issue. They are available through GeForce Experience or at Download Drivers | NVIDIA

Best,
Michel

2 Likes