SOLVED: Lookup CHOP viewer displays but doesn't output value

Hi,

I’m having an issue with my lookup CHOPs not outputting their values. I’m thinking it must have something to do with the nature of my lookup table since it works fine when feeding it a pattern CHOP but I can’t tell what it is.

I have attached a file which should reproduce this behaviour.

lookupchop export bug.2.toe (6.2 KB)

Windows 10 build 15020

Thanks,
Owen

Hey @owenkirby

Thanks for the report.

I had a look and can confirm I see something odd on that trail1. I tried a few things and couldn’t get it to work as you would expect.

I’ve reported it as a bug for a developer to look into it.

Thanks,
Michel

1 Like

Hey @owenkirby

The issue is being looked into.

As a temporary workaround, you can use op('lookup1')['portraitFade'][0], it is giving the data you are expecting.

Best,
Michel

1 Like

The issue is that rename1 has its channel extend conditions set to D / D (or Default , Default).
That is outside the defined sample range, the extend conditions hold the channel value to a constant value (of 0 in this case).

You can see this if you zoom out on rename1 a bit.
The dashed lines stretching out on the left and right are all at value 0.

Since the lookup just creates a single sample on frame1, everywhere else its zero, due to these extend conditions.

Unfortunately the Trail CHOP is set to just capture values falling within the current timeslice window (in this case the extend region which defaults to 0).

Ways around this are:

  1. After rename1, append an Extend CHOP set to : Hold, Hold (This moves the dashed lines up to the first/last value, and behaves well with all CHOPs down the line).

or

  1. After the lookup, append a Shift CHOP set to: Relative to current frame
    (This shifts the single value to the current frame, so it falls within the current timeslice, which the Trail CHOP will catch).

I’d recommend 1, as you’ll get better timesliced data with no chance of flipping to zero during dropped frames.

A little more info:
https://docs.derivative.ca/Extend_Conditions

Cheers,
Rob.

1 Like