SOLVED: macOS Monterey 12.1 and Touchdesigner 2021.15800 on Mini M1. Touchdesigner didn't start

Every technical information in the topic. Tried to reinstall Touchdesigner no chance to get it running. I have to shut it down via cmd+alt+esc. Always the message Touchdesigner does’t react. Ah, btw. Rosetta 2 is installed on the Mini. Any idea to get it running? Or waiting for a new version and going back to my old Macbook Pro with Big Sur?

Hello and sorry for the delay.

2021.15800 is starting on my end in 12.0.1.

I’m upgrading to 12.1 to see if I can reproduce. Will get back.



Just gave it another go after the update and sadly I’m still unable to reproduce it.

Is it occurring with the default file / empty project, or are you trying to run a .toe file you have been working on?

I will see if it can be tested on another M1 machine we own.


gave it also another try. Cleaned the Mac from everything related with TouchDesigner and made a new install. After double click the program I waited roundabout 5 minutes (checking alt+cmd+esc, TouchDesigner was red marked in the the list as doesn’t react), I ignored it, looked into the the console there was a crash report noting MIDIServer has crashed. After 5 Minutes! TouchDesigners main window with the NewProject.1.toe opened. I quit the program and started it again. It takes another five minutes to show up. Meanwhile the startup I opened the Force Quit Application window and also TouchDesigner was marked as not responding for about 4 minutes. Tomorrow I will check if it works without problems.


Hey @Lichtschutzfaktor56

What is the CPU and GPU usage of TD in the activity monitor during those 5 minutes ?

Is there any other process with a high or very high CPU or GPU usage?

Do you see the splash screen? if you click on the progress, it will show a bit more details on what is going on, what do you see?

Did you try an older build ? How does it behave ?


CPU and GPU usage is low (0,5% and 0,0%), immediately after starting TouchDesigner is marked red (does not react). After roundabout 5 minutes Touch Designer jumps up to 99,0% CPU-usage, goes down to 55,0% while the window opens and then jumps up and levels off at 103-104% for a while (2 min) and goes down to 58%.

During the five minutes the process ReportCrash appeared with minimal usage.
The crashreports of the console showed only crashes (4times every minute) of the MidiServer
MIDIServer [882]
Path: /System/Library/Frameworks/CoreMIDI.framework/MIDIServer

There is no other process with a significant high CPU or GPU usage. Chrome, Mail and Activity Monitor are the only running programs. Some agents and helpers (Chrome, DropBox) are also running, no suspicious usage of CPU.

The TouchDesigners splash screen appeared in the moment when TouchDesigner lost his status does not react in the activity monitor after the five minutes.

One day before I reported the behavior of 2021.15800 build I had tried 2021.15020 with similar results.

Regards Michael

Hey @Lichtschutzfaktor56

Thanks for the details.

Did you ever get a dialog opening from MacOS asking for permissions?

If you go to Apple → System Preferences → Security and Privacy

Do you see any mention of TouchDesigner in:

  • Files and Folders ?
  • Full Disk Access ?
  • Camera ?
  • Microphone ?

Can you also confirm that you are trying to start TouchDesigner with an empty project and not opening a previous project file?

Thank you for your time,


Did you ever get a dialog opening from MacOS asking for permissions? No

If you go to Apple → System Preferences → Security and Privacy

Do you see any mention of TouchDesigner in:

  • Files and Folders ? TouchDesigner has access to the Desktopfolder
  • Full Disk Access ? No
  • Camera ? TouchDesigner has access to the camera
  • Microphone ? No

Can you also confirm that you are trying to start TouchDesigner with an empty project and not opening a previous project file? So I have made a “clean install“ of TouchDesigner there are no previous project files on the computer and it starts with the default "Waves of colorful tablets“.

Regards Michael

But after the clean install, it takes 5 minutes to open, if I understood correctly.

Do you have FileVault turned on?


yes after the clean install it takes five minutes to open, and also after I quit the opened program it also takes five minutes. And no, I don’t have FileVault turned on, don’t need my data encrypted.

Hi @Lichtschutzfaktor56
Once you see the splash screen, can you click on the words below the build number and they will expand into more details. Can you tell us what it “says” it is doing during that 5 minutes?

If I understand correctly, you don’t see the splash screen until after the five minutes have elapsed, so Ben’s suggestion might not be relevant.

If you are able, doing the following might help us pinpoint the issue:

  1. Open /Applications/Utilities/Activity Monitor
  2. Select the “CPU” tab
  3. Launch TouchDesigner
  4. In Activity Monitor, select TouchDesigner
  5. Click the button that’s a circle with three dots, and select Sample Process
  6. Save the results of that and attach them to this thread or e-mail them to referencing this forum thread

In addition, it would be helpful to know if you have any other devices connected to the computer.

If you open /Applications/Utilities/Console, do you have any Spin Reports or Crash Reports for TouchDesigner listed? If you could attach or e-mail any of those, that would be a help too.

Sorry you’ve run into this!


so I’ve checked the startup. After 4 seconds the beachball starts spinning. the ball stops after roundabout 2 minutes and was performing 3 quarter turns until the process showed the splashscreen after 5 minutes. “Saying“ NewProject.toe
on click this appears:

Bildschirmfoto 2022-01-06 um 22.01.46

Regards Micha
Remark: I detached all the extern USB-Drive and the Hub. Also tried it with another new user, same behavior.


yes, it is right, the splash screen appears only after 5 minutes. In console I get no spin reports and also no crash reports for TouchDesigner. As you can see in my previous reply, I disconnected for the last check all external devices from the Mac Mini. Just found that I am, as new user, not allowed to attach files to the post, so I will send it via mail.

Regards Michael

Thanks for the sample - very helpful. It looks like TouchDesigner is hanging trying to query MIDI devices, which makes sense with the crashes you saw in the system’s MIDIServer background process. Do you have drivers installed for any MIDI or audio devices, even if the devices themselves are not connected?


oh yes, there must be at least a driver for my Midisport-2X2-device. Short after reading your post I tried to look into The-Audi-MIDI-Setup and in the moment I select the Midi-window the application also crashes. Will have a deeper look into the midithingy. Let you know what I will find out.

Regards Michael


the question about Midi-Driver nailed it! The driver for the old 2x2 Midisport was the culprit. “Schlurp“ burped the trash can and et violà, the TouchDesigner starts immediately. Seems I have to buy a new midi interface.

Thank you for your efforts

Glad to have solved it, but sorry to hear it means new hardware…

I could never describe that sound but I think you nailed it :rofl: