[SOLVED] Python file running in Power shell, not in TD

Hello,
I try to run a Dynamixel servo-motor from TD.
I installed the DynamixelSDK library, I wrote the right com port in the read_write file.
When I run the file from power shell or command line, it works, when I run it from TD, I have an error:

Traceback (most recent call last):
File “</project1/text1:op(’/project1/text1’).run()>”, line 1
td.Error: File “/project1/text1”, line 50
r = previousimport(*args, **kw)
File “C:/Program Files/Python37/Lib/site-packages\dynamixel_sdk_init_.py”, line 22
from .port_handler import *
r = previousimport(*args, **kw)
File “C:/Program Files/Python37/Lib/site-packages\dynamixel_sdk\port_handler.py”, line 23
import serial
r = previousimport(*args, **kw)
ModuleNotFoundError: No module named ‘serial’
Results of run operation resulted in exception.

Perhaps some Python Guru can help me?
Someone succeed using Dynamixel SDK from TD?
Thank you
testPython.toe (5.4 KB)

Hello,
This problem is solved, reinstalling the pyserial library.