SOLVED: TD randomly stops opening DAT in VSCode Ctrl + E

This is a strange bug with either TD or vscode. Every now and again (have not been able to reproduce consistently) Ctrl + E to open dat in VScode just stops working entirely. It will close and reopen VSCode but doesn’t open the selected DAT. This happens at least once per work session making it very difficult to be productive. Restarting VSCode and / or TD does not resolve the issue.

VSCode 1.62.3
TD Commercial 2021.15240 - Windows 10

Has someone at TD tried using VSCode as external editor in the latest build of TD?

This does not work at all currently and there is no other way to edit the temporary files through VSCode. VSCode app opens on Ctrl + E but it doesn’t open the file, just a blank workspace…

Is no one else experiencing this?

Hey @felixfaire

I use VS Code daily. I just gave it a go in 2021.15800 and couldn’t encounter any issue.

Do you have something set in your TD Preferences for DATs → Text Editor ?

Is VS Code your default system-wide?

Did you try to reset / re-install VS Code ?


Reinstalling VSCode worked. Not sure what happened here.