SOLVED: TDAbleton Trouble Connecting Ableton 11/Ventura

Hi Ivan … I’ve been trying to get this to connect for a few weeks off and on. I followed the directions as best as I could. I’ll attach screenshots of remote script errors and textport.

And this error

Yes, this is a bug that will be fixed in next release. For now, you can fix this problem by dragging a TDA_Master device from the TouchDesigner folder in the Live browser into your Master track.

Let me know if that doesn’t work for you!

This seems to have worked! Thanks so much!

Hello Ivan. I’m new to TouchDesigner, but have been using Ableton for many years. I’m trying to set up TD and Ableton 11, but get the attached error message. Can you help? PS: I’ve already dragged a TDA_Master device onto my Master track in Ableton.

@Conscious_Program

This is a known issue and will be fixed in the next release. In this post is a TDAbleton package tox you can use instead of the one in the palette.

For now, that should fix your problem. The other solution is to upgrade to Live 12.

1 Like

Hello Ivan,

Thanks for such a rapid response. This works! I’m looking forward to spending the summer on TD now.

Best wishes,