SOLVED: TouchEngine UE Samples GitHub release “Latest” tag not actually on latest release

I tried opening the TouchEngine UE Samples project in Unreal Engine 5.3.2 but it gives me a “The Following modules are missing or built with a different engine version:” error for TouchEngineUESamp which I guess is just the project file? It asks if I would like to “rebuild them” but clicking yes just says it couldn’t be compiled.

It looks like the Samples Project was made in Unreal Engine 5.3.1, but I don’t think a minor bump from 5.3.1 to 5.3.2 should cause an issue like that, right? Do I need to uninstall 5.3.2 and try 5.3.1 instead? That is a lot of deleting / downloading / waiting just to see if it works or not, especially since I can’t install different minor versions of Unreal Engine simultaneously - aka can’t have 5.3.1 and 5.3.2 installed at the same time.

Hey @Peeet

This should work without issues.

Did you run the project in another version before and just getting back to it ? It could be some 5.3.1 cache causing issues.

Having a look.

Best,
Michel

I cloned a fresh repo with the method detailed in the github.

Double clicked the uproject:
image

Clicked Yes.

Everything rebuilt nicely in the background and opened.

If you had the project opened and built previously, you can try to:

  • Delete the folders Binaries, DerivedDataCache, Intermediate, Saved
  • In the Plugins folder, delete TouchEngine-UE/Intermediate

Well thanks for making me muck around with the GitHub - turns out actually it’s much simpler than that, I’m just not paying as much attention as I thought I was… :-/

I would instead, just like to change this bug report to: TouchEngine UE Samples GitHub release “Latest” tag not actually on latest release…



So in my haste, I was just clicking the release that shows up on the main page…



and not actually getting the latest Samples Files download.

The Plugin page DOES have the latest tag on the latest release, so I was mixing new plugin with old samples file and not noticing the version number mismatch between 1.3.3 and 1.3.4 in the zip files I downloaded.



Downloaded the ACTUAL latest of both and now everything works fine. :slight_smile:

Sorry about that and the time wasted here.

This is fixed.

Best,
Michel

1 Like

No worries, I should have read more into the documentation and (based on experience with Docker, etc) not relied on latest tag. Need to learn how to compile Unreal Projects at some point anyways (just not today)

The documentation is great and the samples file actually super helpful now that I’m digging into it. I thought the banana WAS a lie until I looked up.

1 Like

Very true, it’s not quite a lie anymore.