SOP Particle not showing properly in the display window

I’m new to touchdesigner, so please bear with me if I’m not using the correct terminology. So Im watching a how-to tutorial on youtube and I’m supposed to place a circle operator > transform operator > sort operator > particle operator (using “>” as corrections). I followed these exact steps from the youtube vid, the only difference is the particles on my operator display are black/greyish and hard to see. Whereas the particle on the youtube video are white. I don’t know whats going on but I think it’s affecting the whole project and things aren’t working out like they’re supposed to. If anyone has any idea what I’m talking about or has a solution please let me know. Thanks in advance!

Hi Rob-

First of all, welcome. Second - this sort of thing is very common and TBH doesn’t get a lot less frequent as you gain experience :wink:

It will be much easier to help diagnose what’s going on if you post your .toe file.

N

Sorry for the late reply
paticleRevealPractice.1.toe (3.56 KB)

Hi Rob-

I’m not sure what it looks like on your end but if you’re talking about the particle display in the SOP viewer, they should be white. Does yours look like this?

If you’re having trouble seeing the particles, you could turn on points in the SOP viewer by right-clicking in the viewer and selecting ‘Display Options…’, then selecting the circle next to the the word ‘All:’ (see below)

They’re there, but they’re not white. they’re grey (1st photo). When I hit “Display Options” and follow your steps I get this ( 2nd photo).
Screen Shot 2019-08-26 at 9.45.02 AM.png
Screen Shot 2019-08-26 at 9.39.56 AM.png

Can you post your OS and build?

MacOS Mojave Version 10.14.6
TouchDesigner099 Non-Commercial Build 2019.30550

I get the same… same OS too… you guys found a solution? :slight_smile:

having the same issue! have someone find a solution!
Thanks in advance!

macOS Catalina 10.15.14
TouchDesigner 2020.23680 Commercial

Hi @handsjuan, this is one of those macOS driver bugs where points do not render white correctly. On my mac running 10.14.6, everything works, but it has a discrete GPU. Many of the Intel GPUs on macOS have a few odd openGL problems like this.

To get around this (besides using Display Options mentioned above which also works in any SOP/Geo viewer) I recommend simply setting up a proper render with camera and Render TOP, and using a Constant MAT to easily see those particles as white.
Below see my Macbook rendering okay, also included an updated file from original poster to show the render setup I’m referring to.

paticleRevealPractice.3.toe (4.1 KB)